AnastasiaSokolovskay
13.02.2021 17:28

составить программу в Паскале.
Дано трехзначное (пятизначное, десятизначное) число. Постройте новое число, состоящее из этих же цифр, расположенных в порядке возрастания, используя символьные переменные.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mironova161
13.10.2020 12:13

pascal

Объяснение:

var

 i, j ,k: integer;

 l, lnew: string;

 a: array of integer;

begin

 Write('Введите число >> ');

 ReadLn(l);

 SetLength(a ,length(l));

 for i := 0 to length(l) - 1 do

   a[i] := strtoint(l[i + 1]);    

 for i := 0 to length(l) - 2 do

     for j := i + 1 to length(l) - 1 do

       if a[i] > a[j] then

       begin

         k := a[i];

         a[i] := a[j];

         a[j] := k;

       end;

 

  for i := 0 to length(l) - 1 do

   lnew := lnew + inttostr(a[i]);

 WriteLn('Новое число равно ', lnew);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота