frnkiero1133324
15.09.2020 09:47

Задача 1. Составить программу для вычисления произведения N чисел.

Задача 2. Дано целое число n. Вычислить значение факториала n!
Теория: Рассмотрим, чему равняется 3! (факториал): P=3*2*1=6
Еще один пример: 5!: Р=5*4*3*2*1=120

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ВладимирЛенин1
13.10.2020 12:07

1)var n,i,sum: integer;

a: array [1..1000] of integer;

begin

writeln('Введите кол-во чисел N: ');

read(n);

sum:=1;

for I:= 1 to n do  

sum:=sum*i;

write('Произведение всех чисел = ',sum);

end.

2)var

 n, i, s: integer;

begin

 read(n);

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln(s);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота