0508761681
10.12.2020 07:31

Нужно написать программу, в которой в зависимости от значения погоды выводится сообщение о том, что можно или нельзя купаться. Согласно условиям, купаться можно только при температуре строго больше 15.

Варианты вывода данных:

"Купаться можно"
"Купаться нельзя"
Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
svatoslavsasko3
27.08.2022 15:40
#include <stdio.h>
#include <stdlib.h>

int main()
{
int n=10, k;
int a[n];
int max = 20, min = -20;
int sum=0;
printf("k (<=10) = "); scanf("%d",&k);

srand (time(NULL));
for (int i=0; i<n; i++) {
 a[i] = (float) rand() / RAND_MAX*(max-min)+min;
 printf ("%d ", a[i]);
}
printf("\n");
for (int i = 0; i<k; i++) sum+=a[i];
printf("sum (1..%d) = %d\n", k,sum);
for (int i=1; i<=n-k; i++) {
 sum = sum-a[i-1]+a[i+k-1];
 printf("sum (%d..%d) = %d\n", i+1, i+k, sum);
}
return 0;
}

Пример:
k (<=10) =  5-10 1 -11 -10 16 6 -1 -15 -19 9
sum (1..5) = -14
sum (2..6) = 2
sum (3..7) = 0
sum (4..8) = -4
sum (5..9) = -13
sum (6..10) = -20
0,0(0 оценок)
Ответ:
Иван199928
31.03.2021 12:47

1) 256 цветов, значит 1 пикс - 8 бит = 1 байт

2400/1=2400 пикс.

 

2) 4 цветов, значит 1 пикс - 2 бит

64*128=8192 пикс.

8192*2=16384

16 цветов, значит 1 пикс - 4 бит

32*32= 1024 пикс.

1024*4=4096

 

 3) 640*480=307200 пикс.

307200*3=921600 байт.

28 800 бит/c = 3600 байт/c

921600/3600=256 с.  

 

4) 16 цветов, значит 1 пикс = 4 бит

50*40=2000 пикс.

2000*4=8000 бит.

8000*5=40000 бит/c = 5000 байт/c  

 

5) сканер 

видеокамера 

фотоаппарат 

графический

планшет 

 

6) Переведем разрешающую сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр: 

600/2,54 = 236 точек/см.    

значит размер изображения, 472х708 см.

472*708=334176

334176*8=326 Кбайт

 

7)  тоже самое как в только умножить на 2.

326*2=652 Кбайт

 

8)тоже самое как в поза только умножить на 2,5.

326*2=815 Кбайт

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота