DevilingKeks
11.05.2022 03:10

очень Составить программу ,вычисляющую корни квадратного уравнения используя вложенные ветвления

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Alina970azhieva
21.04.2020 03:39

1. Если алфавит состоит из 64 символов, то для хранения каждого из них необходимо 6 бит, так как 2 ^ 6 = 64, то есть достаточно для хранения алфавита такой размерности.

Для хранения сообщения из 60 символов такого алфавита необходимо 60 * 64 = 3840 бит.

Таким образом, сообщение несет 3840 : 8 = 480 байт информации.

2. 0.25 кбайт = 256 байт = 2048 бит

3. 2.5 кБайт = 2560 байт.

2560 байт / 2560 символов = 1 байт/символ

1 байт = 8 бит

8 бит = 256 вариантов (от 00000000 до 11111111).

ответ: 256 символов в алфавите

0,0(0 оценок)
Ответ:
oksiz72
27.03.2021 14:28

--- Python 3.8.3 ---

def ReadSeq(SeqLen: int, SeqType = int):

   '''

   Возвращает последовательность элементов в указанном типе, считанных с клавиатуры, заданной длины.

   '''

   try:

       for _ in range(SeqLen):

           yield SeqType(input())

   except TypeError:

       raise RuntimeError(f'Unsupported type: {CastType}')

def main():

   n = int(input())

   Numbers = ReadSeq(n)

   print(sum(filter(lambda i: i % 6 == 0, Numbers)))

       

if __name__ == "__main__":

   main()

Программа эффективна по памяти, т.к в любой момент её работы с памяти храниться только один элемент последовательности

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота