Лиза45111
11.12.2020 20:30

с программированием С++.Написать программу,которая для числа в десятеричной системе исчисления выводит это же число в двоичной и в шестнадцатиричной

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
natashakuznecz1
12.11.2021 14:48

(см. объяснение)

Объяснение:

Напишем программу на Python 3:

k = 0

for i in input():

   if (ord(i) in range(65, 91)) or (ord(i) in range(97, 123)):

       k += 1

print(k)

Задание выполнено!

Комментарий 1:

Замечу, что то же самое легко сделать на паскале:

##

var k: integer := 0;

foreach var c: char in ReadString do

 if((ord(c) in [65..90]) or (ord(c) in [97..122]))

   then k:= k+1;

print(k);

Комментарий 2:

Задачу можно было решить несколько иначе:

k = 0

for i in input():

   if ('a' <= i <= 'z') or ('A' <= i <= 'Z'):

       k += 1

print(k)

Комментарий 3:

Решение из комментария 2 тоже несложно написать на паскале:

##

var k: integer := 0;

foreach var c: char in ReadString do

 if((c in ['a'..'z']) or (c in ['A'..'Z']))

   then k:= k+1;

print(k);

0,0(0 оценок)
Ответ:
valeraadyan
04.10.2020 17:14

Відповідь: a) 5; б) list.append(x); в) 4; г) list.extend(); д) 3

а) 5

Перевірка:

list_ = [1, 1, 1, 2, 3, 4]

print(list_.count(1))

вихідні дані:

3

б) 1 або 2, там однакові відповіді

Перевірка:

list_ = [1, 2, 3]

list_.append(10)

print(list_)

вихідні дані:

[1, 2, 3, 10]

в) 4

Перевірка:

list_ = [1, 2, 3]

list_.clear()

print(list_)

вихідні дані:

[]

г) list.extend()

Перевірка:

list_ = [1, 2, 3]

list2 = [4, 5, 6]

list_.extend(list2)

print(list_)

вихідні дані:

[1, 2, 3, 4, 5, 6]

д) 3

Перевірка:

list_ = input().split()

list_.reverse()

print(*list_)

вхідні дані:

1 2 3 4 5

вихідні дані:

5 4 3 2 1

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота