Veratandashvili
07.01.2020 02:12

Написать программу обработки двумерного целочисленного массива 7х7 на Паскале.
Элементы массива вводятся случайным образом. Предусмотреть ввод отрицательных элементов.
Первоначальный и получившийся массивы вывести на экран.
Найти: Сумму элементов главной
Если: Найденная сумма положительна
То Обнулить элементы выше главной диагонали

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katerinadrobot
18.04.2023 00:31

quantity = 0

n = int(input())

array = []

counter = 0

while counter != n:

 number = int(input())

 array.append(number)

 counter += 1

for i in range(len(array)):

   for j in range(i + 1, len(array)):

     if ((array[i] * array[j]) % 6 == 0):

       quantity += 1

print(quantity)

Объяснение:

quantity = 0  // Переменная, хранящая количество чисел, равна 0

n = int(input())  // Ввод с клавиатуры количества чисел

array = []  // Создание списка

counter = 0  // Переменная счетчик = 0

while counter != n:  // Пока переменная счетчик ≠ значению переменной n

 number = int(input())  // Ввод числа с клавиатуры

 array.append(number)  // Добавление этого числа в список

 counter += 1  // Переменная счетчик + 1

for i in range(len(array)):  // От 0-го индекса до размера списка

   for j in range(i + 1, len(array)):  // От i + 1 индекса до размера списка (берется значение после индекса i, чтобы сократить время)

     if ((array[i] * array[j]) % 6 == 0):  // Если индекс i списка * индекс j списка делится на 6 без остатка

       quantity += 1  // Количество + 1

print(quantity) // Вывод значения переменной quantity

0,0(0 оценок)
Ответ:
Памагити1111111
18.04.2023 00:31

quantity = 0

n = int(input())

array = []

counter = 0

while counter != n:

 number = int(input())

 array.append(number)

 counter += 1

for i in range(len(array)):

   for j in range(i + 1, len(array)):

     if ((array[i] * array[j]) % 6 == 0):

       quantity += 1

print(quantity)

Объяснение:

quantity = 0  // Переменная, хранящая количество чисел, равна 0

n = int(input())  // Ввод с клавиатуры количества чисел

array = []  // Создание списка

counter = 0  // Переменная счетчик = 0

while counter != n:  // Пока переменная счетчик ≠ значению переменной n

 number = int(input())  // Ввод числа с клавиатуры

 array.append(number)  // Добавление этого числа в список

 counter += 1  // Переменная счетчик + 1

for i in range(len(array)):  // От 0-го индекса до размера списка

   for j in range(i + 1, len(array)):  // От i + 1 индекса до размера списка (берется значение после индекса i, чтобы сократить время)

     if ((array[i] * array[j]) % 6 == 0):  // Если индекс i списка * индекс j списка делится на 6 без остатка

       quantity += 1  // Количество + 1

print(quantity) // Вывод значения переменной quantity

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота