FantomLord24
26.10.2022 17:10

Необходимо написать программу решения квадратного уравнения в Паскаль (программу можно скачать тут ) и решить при нее квадратные уравнения:

3х2 -10х +1=0

0,5х2+2х - 4=0

4х2 + х - 6=0

2х2 + 3х +8=0

х2 +4 =0

5х2 -8х = 0

1,5х2-0,6х - 4,8 = 0

-2х2+4х - 8 = 0

9х2+4х -7 = 0

0,1х2- 9 = 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЧерепашкаВася
31.03.2020 08:19
ответ:  17

// delete.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include "iostream"#include <conio.h>
using namespace std;
int count_ = 0;
char m[6][6] = { {'S', '.', '.', '.', '#', '#'}, { '#', '.', '#', '.', '.', '.' }, { '.', '.', '#', '.', '.', '#' }, { '.', '.', '#', '#', '#', '.' }, { '#', '.', '.', '.', '#', '#' }, { '#', '#', '#', '.', '.', 'F' }};
int find_p(int x, int y) { if (x < 0 || x > 5 || y < 0 || y > 5) return 0; if (m[y][x] == 'F') return 1; if (m[y][x] != '.' && m[y][x] != 'S') return 0; m[y][x] = '+'; count_++; if (find_p(x, y - 1)) return 1; if (find_p(x + 1, y)) return 1; if (find_p(x, y + 1)) return 1; if (find_p(x - 1, y)) return 1; m[y][x] = 'x'; return 0;}

int main(){ find_p(0, 0); cout << count_; //вывод _getch(); // задержка    return 0;}
0,0(0 оценок)
Ответ:
maksim22771
28.09.2022 22:11
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString.ToUpper; // к верхнему регистру
  var (kO,kE):=(0,0); // счетчики
  for var i:=1 to s.Length do
    case s[i] of
    'О':ko+=1;
    'Е':kE+=1
    end;
  if kO>kE then Writeln('Буква "О" встречается чаще')
  else if kO<kE then Writeln('Буква "Е" встречается чаще')
  else Writeln('Буквы "О" и "Е" встречаются одинаковое число раз')
end.

Пример
Если бы Ольга захотела, она бы училась лучше Елены
Буква "Е" встречается чаще
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота