Anotherdream
18.10.2022 15:27

Задача1.Составить программу обработки массива размерностью n, заполненного целыми числами, введенными с клавиатуры. Вывести индексы и значения положительных элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Natashkasunny05
13.10.2020 00:12

var

 arr:array[1..1000] of integer;

 i,n:integer;

begin

 write('Укажите размер массива - ');

 read(n);

 

 writeln;

 

 for i:=1 to n do

 begin

   read(arr[i]);

 end;

 for i:=1 to n do

   if arr[i]>0 then writeln('Эл-т - ',arr[i],' Номер - ',i);

 

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота