resssnizisss
12.08.2022 12:08

Напишите программу для работы со списком из произвольного количества учеников (не больше 50). О каждом ученике запрашивается Имя, Отчество, Фамилия, возраст, номер и буква класса. По завершении ввода, выводится список учеников (один ученик на строке) упорядоченный в порядке убывания по Имени. Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Элис6666666666
13.10.2020 00:25

// PascalABC.NET 3.6

type

 TR = record

   Имя, Отчество, Фамилия: string;

   Возраст, НомерКласса: integer;

   БукваКласса: char;

 end;

 

function ПринятьСведения: TR;

 begin

   Result.Имя := ReadlnString('Имя:');

   Result.Отчество := ReadlnString('Отчество:');

   Result.Фамилия := ReadlnString('Фамилия:');

   Result.Возраст := ReadlnInteger('Возраст:');

   Result.НомерКласса := ReadlnInteger('Номер клвсса:');

   Result.БукваКласса := ReadlnChar('Буква класса:');

 end;

 

procedure ВывестиСведения(L: List<TR>);

begin

 foreach var r in L do

   Writeln(r.Имя+' '+r.Отчество+' '+r.Фамилия:40,

      r.Возраст:4, r.НомерКласса+r.БукваКласса:4)

end;

 

begin

 var p := new List<TR>;

 var n := ReadlnInteger('Сколько учеников добавить?');

 loop n do

   p.Add(ПринятьСведения);

 p := p.OrderByDescending(t -> t.Имя).ToList;

 ВывестиСведения(p);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота