DEMON8800
02.01.2020 11:18

Напишите программу, которая суммирует все числа в диапазоне от 4 до 32 и вычисляет их среднее арифметическое, выводит эти числа на экран в строчку и на отдельных строках выводит сумму и среднее арифметическое

ОЧЕНЬ ВАЖНО! ДАМ ВЫСШУЮ НАГРАДУ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sema1488
13.10.2020 00:27

var  

 S,SA:real;

 i,k:integer;

begin

 S:=0;

 

 SA:=0;

 

 for i:=4 to 32 do

 begin

  S:=S+i;

  k:=k+1;

 end;

 SA:=S/k;

 

 write('Sum = ',S,'   Arithmetic mean = ',SA);

end.  

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота