mol202kj00
15.10.2020 17:38

Написать программу. Пользователь вводит целое число. Если оно является четным и находится между 30 и 40, то вывести на экран его куб. В противном случае написать исходное число.
Написать программу. В компьютер вводится число. Если оно не находится между 30 и 40, то написать "Мимо", в противном случае "Попал".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
uncu4ek
03.08.2022 05:25

вот не забудь нажать Объяснение:

var

   arr : Array[1..100] Of ShortInt;

   temp : ShortInt;

   i, j, n : Byte;

begin

   Write('n='); ReadLn(n);

   Randomize;

   for i := 1 to n do

   begin

       arr[i] := Random(11) - 5;

       Write(arr[i], ' ');

   end;

   WriteLn; WriteLn;

   for i := 2 to n do

       for j := n downto i do

           if (((arr[j - 1] <= 0) And (arr[j] > 0)) Or ((arr[j - 1] < 0) And (arr[j] = 0)))

           then

           begin

               temp := arr[j - 1];

               arr[j - 1] := arr[j];

               arr[j] := temp;

           end;

   for i := 1 to n do

       Write(arr[i], ' ');

end.

0,0(0 оценок)
Ответ:
49583
27.12.2022 21:23
Romanf romanf отличник 2013-01-10t16: 13: 22+00: 00 1. подумать над алгоритмом 2. вот сам алгоритм: а. спросить у пользователя значения б. расчитать ответ в. выдать ответ на экран 3. написать код в паскале 4. исправить ошибки компиляции 5. протестировать, вводить разные числа 6. обнаружила, что если вводить числа наугад ответ получается отрицательным иногда 7. вставить код проверки введенных пользователем значений 8. убрать ошибки компиляции 9. протестировать 10. готово а вот и сама программа: program aerobus; uses crt; const totalplace = 160; var businessplaces, economyplaces: integer; businessprice, economyprice: real; totalcharge: real; a,b: integer; correctinput: boolean; begin clrscr; businessplaces: =totalplace div 4; economyplaces: = totalplace - businessplaces; writeln('business places count: ', businessplaces); writeln('economy places count: ', economyplaces); correctinput: =false; while not correctinput do begin write('please input business class ticket price: '); readln(businessprice); if(businessprice> 0) then begin correctinput: =true; end else begin writeln('the price should be a positive number, please try again'); end; end; economyprice: =businessprice/2; writeln('economy ticket price is: ', economyprice: 0: 2); correctinput: =false; while not correctinput do begin write('how many business tickets are left? : '); readln(a); if(a> =0) and (a< =businessplaces)then correctinput: =true; if(a< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(a> businessplaces) then begin writeln('please input a number which is less or equal to the tolal business place count, please try again'); end; end; correctinput: =false; while not correctinput do begin write('how many economy tickets are left? : '); readln(b); if(b> =0) and (b< =economyplaces)then correctinput: =true; if(b< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(b> economyplaces) then begin writeln('please input a number which is less or equal to the tolal economy place count, please try again'); end; end; totalcharge: =(businessplaces-a)*businessprice; totalcharge: =totalcharge+(economyplaces-b)*economyprice; writeln('the total charge is: ', totalcharge: 0: 2); writeln; writeln('press enter to exit'); readln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота