Иван54654
12.07.2020 16:22

Составить алгоритм и написать программу(на паскале) "найти минимальное значение тригонометрической функции
(любой) на интервале [0; 1) . Перебор осуществлять с шагом

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ayupovailinaozhaxj
21.06.2020 06:00
Рассмотрим простейшую схему кредитования (и самую невыгодную для заёмщика), когда за каждый год отдается фиксированный процент p от первоначальной суммы кредита k без учета того, что часть кредита уже погашена за предыдущие годы.
В этом случае ежегодная сумма процентов по кредиту составит Sk=k×p%/100%.
За n лет будет отдано n×Sk. И еще нужно вернуть саму сумму кредита k.
Итого нужно вернуть k+n×Sk.
Доход за это время составит n×r и получаем неравенство
n×r ≥ n×Sk+k
n×(r-Sk) ≥ k → n ≥ k/(r-Sk) с округлением до целых в большую сторону.

// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (k,p):=ReadReal2('Сумма кредита и процент годовых:');
  var r:=ReadReal('Предполагаемый годовой доход:');
  var Sk:=k*p/100;
  if r<=Sk then Writeln('Рассчитаться за кредит невозможно')
  else Writeln('Количество лет на погашение кредита: ',Floor(k/(r-Sk)))
end.

Пример
Сумма кредита и процент годовых:10 0000 16
Предполагаемый годовой доход: 24000
Количество лет на погашение кредита: 12
0,0(0 оценок)
Ответ:
swdw1
19.08.2022 23:21

var

 n, k, s, sa: integer;

 

begin

 k := 0;

 s := 0;

 sa := 0;

 writeln('Введите последовательность, окончание ввода - число 0');

 repeat

   read(n);

   if (n mod 4 = 0) and (n mod 10 = 2) then s := s + n;

   if (n <> 0) and (n < 100) then inc(k);

   sa := sa + n

 until n = 0;

 readln;

 writeln('Сумма чисел, кратных 4 и заканчивающихся на 2, равна ', s);

 writeln('Количество чисел, не больших 100, равно ', k);

 writeln('Сумма последовательности равна ', sa);

 readln

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота