мот43
15.06.2021 09:12

Составьте программу на языке Free Pascal. Задача: вести с клавиатуры элементы массива М[7], вывести сумму всех элементов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Малиш999
07.03.2023 17:06

1) Название программы

2)Описание постоянных переменных

3)Описание переменных

4)Начало

5)Параметрический цикл от 1 до N элементов

Вывод a[i]=  (где i-число из цикла)

Ввод  элемента в массив a под номер i

5)конец цикла

6)Присваиваем переменной max значение первого элемента массива

7)Параметрический цикл от 2 до n элемента

(Там не дописана программа частично после if, должно быть так:)

8) если максимальный элемент меньше a[i] элемента, то максимальному присваиваем значение a[i]

9) Вывод Найбільший елемент масиву max= (max число)

10) конец программы

0,0(0 оценок)
Ответ:
djonli1
30.03.2023 12:15
Type
  mass = array[1..10, 1..10] of real;

var
  a, b, c: mass;
  n, m, i, j, n1, m1: integer;

procedure MatrA(var a: mass);
var
  i, j: integer;
begin
  for i := 1 to n do
    for j := 1 to m do
    begin
      writeln('a[', i, ',', j, ']: ');
      readln(a[i, j])
    end
end;

procedure MatrB(var b: mass);
var
  i, j: integer;
begin
  for i := 1 to n1 do
    for j := 1 to m1 do
    begin
      writeln('b[', i, ',', j, ']: ');
      readln(b[i, j])
    end
end;

procedure Sum(a, b: mass; var c: mass);
var
  i, j: integer;
begin
  for i := 1 to n do
    for j := 1 to m do
      c[i, j] := a[i, j] + b[i, j];
end;

begin
  writeln('Введите n,m матрицы A');
  readln(n, m);
  MatrA(a);
  writeln('Введите n,m матрицы B');
  readln(n1, m1);
  MatrB(b);
  if (n1 <> n) and (m1 <> m) then
    writeln('Матрицы сложить нельзя')
  else begin
    Sum(a, b, c);
    writeln('A+B');
    for i := 1 to n do
    begin
      for j := 1 to m do
        write(c[i, j]:1:3, ' ');
      writeln
    end
  end;
  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота