ArinaGaGara
09.09.2020 01:16

исправить
Напишите программу, которая находит минимальный и максимальный элементы из элементов матрицы с четными положительными значениями и их индексы. учтите, что таких элементов в матрице может и не быть.
begin
var m:=ReadInteger('Число строк=');
var n:=ReadInteger('Число стролбцов=');
var a:=MatrixRandom(m,n,-99,99);
var imax:=-1; var jmax:=0;
var imin:=0; var jmin:=0;
var min:=100; var max:=-100; // больше большего, меньше меньшего
for var i:=0 to m-1 do begin
for var j:=0 to n-1 do begin
Write(a[i,j]:4);
if (a[i,j]>0) and (a[i,j] mod 2=0) then begin
if a[i,j] if a[i,j]>max then begin imax:=i; jmax:=j; max:=a[i,j] end
end
end;
Writeln
end;
if imax<>-1 then begin
Writeln('Минимальный четный положительный элемент A[',
imin+1,',',jmin+1,']=',a[imin,jmin]);
Writeln('Максимальный четный положительный элемент A[',
imax+1,',',jmax+1,']=',a[imax,jmax])
end
else
Writeln('В массиве нет положительных четных элементов')
end.

Тестовое решение
Число строк= 5
Число стролбцов= 8
-59 98 55 -92 -98 68 5 -82
63 49 41 7 51 22 55 -4
-78 42 -35 -60 -6 -15 -34 -28
-14 55 -44 22 74 -50 -98 85
50 2 65 39 -47 -59 -7 -87
Минимальный четный положительный элемент A[5,2]=2
Максимальный четный положительный элемент A[1,2]=98

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Fire73
28.02.2022 08:04

1)К системному ПО относятся:

операционные системы (эта программа загружается в ОЗУ при включении компьютера)

программы – оболочки (обеспечивают более удобный и наглядный общения с компьютером, чем с командной строки DOS, например, Norton Commander)

операционные оболочки – интерфейсные системы, которые используются для создания графических интерфейсов, мультипрограммирования и. т.

Драйверы (программы, предназначенные для управления портами периферийных устройств, обычно загружаются в оперативную память при запуске компьютера)

утилиты (вс или служебные программы, которые представляют пользователю ряд дополнительных услуг)

2) OpenOffice - это программа для работы с офисными документами

3) в него входят такие приложение как: Writer-(текстовый редактор),

Calc - электронные таблицы,Draw – графический редактор,Base – поддержка работы с базами данных,Math- формульный редактор.

5)Calc - это модуль электронных таблиц, позволяющий обрабатывать и визуализировать табличные данные. В электронную таблицу можно вводить данные, обычно числовые, и затем манипулировать этими данными для получения определенных результатов.

6)строки - цифрами, столбцы - английскими буквами, затем удвоенными, утроенными и так далее.

7)Выделяем таблицу и переходим в меню Данные – Сводная таблица.

Теперь необходимо выбрать источник данных. Используем выделенную ранее таблицу (ставим отметку напротив пункта «Текущее выделение»

8)Установив OpenOffice.org и запустив текстовый редактор или программу для работы с электронными таблицами, вы увидите привычный интерфейс с теми же пунктами меню и панелями инструментов. В пунктах "Сервис", "Формат", "Правка"

0,0(0 оценок)
Ответ:
ArturRus2004
03.02.2023 17:34

Прежде чем уменьшить пробелы между словами в тексте, необходимо выяснить причину, по которой они возникли. Их может быть несколько: выравнивание текста по ширине;  лишние пробелы;  знак табуляции между словами или использование длинных пробелов. Все эти проблемы могут возникнуть, например, вследствие копирования текста из Интернета. Чтобы привести текст в должный вид, необходимо по порядку избавиться от всех вышеназванных причин. Выравнивание текста . Частая причина появления большого интервала между словами – выравнивание текста по ширине. При таком выравнивании слова равномерно распределяются по всей длине строки за счет увеличения расстояния между ними.  

Объяснение: более подробно можете поискать в интернете. Удачи)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота