fhdsjkfalhd
06.06.2022 18:58

составьте программу в паскале abs. найти произведение чисел от 1 до n. через цикл while и repeat​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
andreyyazyninp0875c
13.10.2020 11:08

1. while

var i,n: integer;

p: real;

begin

write('Введите число: ');//n<171

read(n);

p:=1;

i:=1;

while i<=n do

begin

p:=p*i;

i:=i+1

end;

write ('Произведение чисел от 1 до ',n,' равно ',p)

end.

2. repeat

var i,n: integer;

p: real;

begin

write('Введите число: ');//n<171

read(n);

p:=1;

i:=1;

repeat

p:=p*i;

i:=i+1

until i>n;

write ('Произведение чисел от 1 до ',n,' равно ',p)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота