иаешшвеэщк
17.06.2022 01:02

написать программу. Паскаль
Введите с клавиатуры три числа и выведите их в столбик в правой части экрана: синим цветом числа до -5, красным цветом числа от -5 до 5 включительно, зелёным цветом числа больше 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
EgorT222
23.11.2022 23:46
#include <iostream>#include <ctime>//Бібліотека для рандомуusing namespace std;int main(){ int array[10];//Масив int Max_Num=0,Min_Num=0;// Мінімальне і Максимальне числа bool Positive_or_negative=0;//Число додатнє чи відємне srand(time(NULL));//Рандом.Кожний раз інший. for(int i=0;i<10;++i) { Positive_or_negative=rand()%2; if(Positive_or_negative==false)//якщо Positive_or_negative==0 { array[i]=-(rand()%10);//Рандом від -10...0 } else { array[i]=rand()%10;//Рандом від 0...10 } if(array[i]>Max_Num)//Пошук макс. числа { Max_Num=array[i]; } if(array[i]<Min_Num)//Пошук Мін. числа { Min_Num=array[i]; } cout<<array[i]<<" "; } cout<<endl<<"Max. number is:"<<Max_Num<<endl;//Вивід максимально числа cout<<"Min. number is:"<<Min_Num<<endl;//Вивід мінімально числа system("pause>>void");//закінчення программи.}
0,0(0 оценок)
Ответ:
kholov03
24.08.2021 08:13

Давайте разбираться. s>A or t>11 - это условие будет выполняться тогда, когда хотя бы одно из неравенств выполнится и это важно: нам не обязательно, чтобы выполнялись оба неравенства. Рассмотрим наборы, у которых второе число больше 11:

(5,12) - единственный набор.

У нас осталось 8 наборов, из которых 3 раза должно вывестись NO.

Найдём самые маленькие значения у первой цифры в наборах:

(-9,11) , (2,7) и (2,-2).

Нам нужно, чтобы эти три набора не выполнились, а значит эти цифры не должны оказаться больше чем А. Наименьшим А, которое нас в таком случае устраивает будет 2

ответ: 2

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота