даша7642269
29.06.2021 04:37

Умоляю У вас есть персонаж, обладающий рядом и статов.
Напишите программу по заданным условиям: 1. Персонаж имеет набор статов: strength, dexterity, intelligence, wisdom, charisma. Каждая стата имеет свой запас.
Домашнее задание № 9
2
Значения запасов каждой статы должны быть случайны – в пределах от 60 до 80 и быть представлены в списке
stats = []:
В начале игры пользователю предоставляется возможность однократно повысить одну стату на случайное количество единиц – от 5 до 15:
Обратите внимание, что повышая одну стату на сгенерированное число, все остальные должны уменьшиться на случайное значение в пределах от 5 до 15:
Персонаж обладает набором скилов: fireball, lightning, silence, fire ward.
Использование каждого из них отнимает разное количество единиц статов, а именно:
Занесите эти данные в список, чтобы в дальнейшем воспользоваться ими в игре:
Предоставьте пользователю возможность использовать скилы, например, по нажатию f применяется Fireball, l – Lightning и т. д. После применения какой-либо из запас статов будет уменьшаться, согласно приведенной выше таблице. Рассмотрим следующий пример: 1. Было Stats: 70 64 63 80 65. 2. Применили Fireball: 12 15 28 10 5. 3. Стало Stats: 58 49 35 70 60. Следите за тем, чтобы элементы в списке stats = [] не стали отрицательными. Результат работы: файл с расширением .py. Выбор ПО на ваше усмотрение: Atom, PyCharm, Python IDLE или др решить даный во

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Bogalexx
03.10.2020 05:40

согласно исследованиям руководитель от 50 до 90% всего времени тратит на коммуникации. это кажется невероятным, но становится понятным, если учесть, что руководитель занимается этим, чтобы реализовать свои роли в межличностных отношениях, информационном обмене и процессах принятия решений, не говоря об функциях планирования, организации, мотивации и контроля. именно потому, что обмен информацией встроен во все основные виды деятельности, мы называем коммуникации связующим процессом.

поскольку руководитель исполняет три свои роли и осуществляет четыре основные функции, с тем, чтобы сформулировать цели организации и достичь их, качество обмена информацией может прямо влиять на степень реализации целей. это означает, что для успеха индивидов и организаций необходимы эффективные коммуникации.

хотя общепризнанно, что коммуникации имеют огромное значение для успеха организаций, опросы показали, что 73% американских, 63% и 85% японских руководителей считают коммуникации главным препятствием на пути достижения эффективности их организациями. согласно еще одному опросу примерно 250 тыс. работников 2000 самых разных компаний, обмен информацией представляет одну из самых сложных проблем в организациях. эти опросы показывают, что неэффективные коммуникации - одна из главных сфер возникновения проблем. глубоко осмысливая коммуникации на уровне личности и организации, мы должны учиться снижать частоту случаев неэффективных коммуникаций и становиться лучшими, более эффективными менеджерами. эффективно работающие руководители - это те, кто эффективны в коммуникациях. они представляют суть коммуникационного процесса, хорошо развитым умением устного и письменного общения и понимают, как среда влияет на обмен информацией. начнем с анализа коммуникационного процесса в организациях. размышляя об обмене информацией в организации, обычно думают о людях, которые говорят в процессе личного общения или в группах на собраниях, разговаривают по телефону или читают и составляют записки, письма и отчеты. хотя на эти случаи приходится основная часть коммуникаций в организации, коммуникации представляют собой всепроникающий и сложный процесс

0,0(0 оценок)
Ответ:
MagistooorNaine
10.06.2021 16:50
Pascalabc.net 3.4.0, сборка 1675 от 12.06.2018 внимание! если программа не работает, обновите версию! procedure println(self: array of real); extensionmethod; begin   self.batch(5).foreach(s->           begin foreach var p in s do write(p: 15: 10); writeln end);   writeln(min(15*(self.count div 2),38)*'- ') end; begin   var m: =arrgen(readinteger('n='),i-> cos(i),1); m.println;   var (a,b): =readreal2('введите границы a b: ');   writeln('число элементов на интервале [',a,',',b,'] равно ',       m.where(t-> t.between(a,);   write('сумма элементов, расположенных после максимального, равна ');   var imax: =m.indexmax;   (m? [imax+1: ].sum).println;   writeln('элементы, по убыванию модулей');   m: =m.orderbydescending(t-> abs(; m.println; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота