оспшро
28.05.2021 07:24

Дан фрагмент программы, определите значение переменной b.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
qweasdzxcrfvtgbmn
10.01.2020 03:01
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016

function gcd(a,b:integer):integer;
// Нахождение НОД
begin
  while b<>0 do
  begin
    a:=a mod b;
    var i:=b; b:=a; a:=i
  end;
  Result:=a
end;

procedure Shorter(var a,b:integer);
// "сокращатель" дроби
begin
  var k:=gcd(a,b);
  a:=a div k;
  b:=b div k
end;

begin
  var a,b:integer;
  Writeln('Введите числитель и знаменатель дроби: ');
  Read(a,b);
  Write(a,'/',b,'='); Shorter(a,b); Writeln(a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби:
25 15
25/15=5/3
0,0(0 оценок)
Ответ:
Lori04
14.08.2020 23:31
Информационная деятельность - это совокупность действий, направленных на удовлетворение информационных потребностей граждан, юридических лиц и государства.
В целях удовлетворения этих потребностей органы государственной власти и органы местного и регионального самоуправления создают информационные службы, системы, сети, базы и банки данных.
Порядок их создания, структура, права и обязанности определяются Кабинетом Министров Украины или другими органами государственной власти, а также органами местного и регионального самоуправления.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота