kostetXD
09.02.2020 23:29

Изучите блок-схему и напишите программу на языке С++ в среде Code Blocks

#include

using namespace std;

int main ()

{int ответ
, ответ
;

S = ответ
;

for (i=ответ
; ответ
<=ответ
; i+=ответ
)

{

S=ответ
;

}

cout << "S= " << ответ
;

return 0;

}

Рассчитайте и укажите какое получится значение S = ответ

Исправьте фрагменты программы, содержащие пустые окна на соответствующий код для получения результата решения данной задачи.

Для ответов воспользуйтесь следующими словами и данными, вписав их в пустые окна ответов (величина рассчитанного значения S не указана):

S (использовать 3 раза)

i (использовать 3 раза)

0 (использовать 2 раза)

2 (использовать 1 раз)

20 (использовать 1 раз)

+ (использовать 1 раз)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
makareevakarina17
09.01.2022 16:06

Особенность этих указаний в том, что исполнитель не может уклониться от выполнения пунктов одного за другим, даже если из предыдущих пунктов известно, что очередное действие бессмысленно. Например, если a = 5 и b = 5, то после выполнения 3 пункта мы получим 0, и деление станет невозможным. Однако исполнитель все равно попытается его выполнить (и получит ошибку!), потому что не умеет различать такие ситуации.

Из-за этой особенности алгоритмы чисто линейной структуры находят очень ограниченное применение. Любая достаточно сложная задача предполагает ситуации типа "а если... сделать так-то, если же нет - сделать что-то другое". Т.е. порядок выполнения плана зависит от каких-то условий, и, значит, линейность нарушается.

Но, строго говоря, любой план при достаточно большом обобщении имеет линейную последовательность выполнения, хотя отдельные его пункты могут предполагать вариантность. Поэтому линейную структуру можно рассматривать как "каркас" сложного плана, как базисную его структуру.

0,0(0 оценок)
Ответ:
tinaZ07
09.01.2022 16:06

Свойства алгоритма

Их несколько: — конечность. Любой алгоритм должен быть завершённым, а окончание наступает после выполнения определённого числа шагов; — однозначность, понятность. Не допускается разных толкований, неопределённости и двусмысленности — всё должно быть чётко и ясно, а также понятно исполнителю — и правила выполнения действий линейного алгоритма, и сами действия; — результативность. Итог работы — результат, полученный за конечное число шагов; — универсальность, массовость. Качественный алгоритм решать не одну задачу, а целый класс задач, имеющих схожую постановку/структуру

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота