max50chepil
13.01.2021 19:48

Составить программы в PascalABC:

1. Составить программу нахождения произведения цифр вводимого с клавиатуры четырёхзначного числа. (Например, число 2351, результат 30).

2. Составить программу нахождения среднего арифметического квадратов двух чисел, введённых с клавиатуры. (Например, числа 2 4, результат 10)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Viktoriya24101
13.10.2020 10:37

Задача 1:

var a,s: integer;

begin

write('Введите четырёхзначное число: ');

readln(a);

s:=1;

while (a>0) do

 begin

 s:=s*(a mod 10);

 a:=a div 10;

 end;

write('Произведение цифр введённого четырёхзначного числа: ',s);

end.

Задача 2:

var a,b: integer;

var s: real;

begin

write('Введите два числа: ');

readln(a,b);

s:=(a*a+b*b)/2;

write('Среднее арифметическое квадратов двух введённых чисел: ',s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота