. Наберите и выполните программу в среде программирования Паскаль. В комментариях
вместо во запишите ответы на них. Результирующую программу отправьте учителю:
Var I, N, m: integer; //Что делает эта программа?
Begin
Readln(N); //Что вводим в этой строке и зачем? Как можно подсказать пользователю, что ввести?
Writeln(‘Таблица квадратов чисел от 1 до N’); //Сколько раз выполняется этот оператор?
For i:=1 to N do //Сколько раз выполнится цикл?
Begin //Зачем снова писать операторные скобки?
m:=i*I;
Writeln(I, ‘ ‘,m); //Как по-другому оставить пробелы между столбиками?
End;
End.
2. Задание то же
Var n: integer; a:real; //Что делает эта программа? Почему a не может быть целым числом?
Begin
For n:=1 to 7 do //Сколько раз выполнится цикл?
Begin //Зачем снова писать операторные скобки?
a:=(n*n+5)/(2*n);//Запиши в тетрадь формулу последовательности в математической форме
Writeln(n:5, a:10:2); //Сколько знаков после запятой в значении переменной a? Почему? Что
значитa:10:2?
End;
End.
3. Задание то же
Var n: integer; a, S:real; //Что делает эта программа?
Begin
S:=0; //Зачем записывать в S ноль?
For n:=1 to 5 do //Сколько раз выполнится цикл?
Begin
a:= 5+n*n/2*n;//Запиши в тетрадь формулу последовательности в математической форме
S:=S+a;//Что происходит в этой строке программы?
End;
Writeln(‘Сумма 5-ти элементов последовательности S=’,S:9:4); //Почему мы выводим результат
//после окончания цикла? Сколько чисел в ответе?
End.
4. Составь и выполни программу вычисления произведения элементов последовательности.
Формула последовательности – из задания №2.