lalala106
06.03.2021 09:54

Напишите программу которая заполняет элементы квадратной матрицы размером NxN лежащие нижи побочной диагонали значения -1, а остальные увеличиваются на 1. матрицу надо заполнить случайными числами в интервале [10,90]

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ДЭМКО
01.08.2020 11:04

Хотелось бы конечно определиться с границами массива, но раз они не заданы, то допустим, что массив имеет размерность 10х10. Также нам неизвестен тип данных (целочисленный или вещественный), так что допустим, что массив заполняется целочисленными элементами. Тогда, программа примет следующий вид:

 VAR

A: ARRAY [1..10, 1..10] OF INTEGER;

 i, j: BYTE; {Переменные-счётчики циклов}

 flag: BOOLEAN: {переменная флаг логического типа, сигнализирующая о наличии или отсутствии отриц.элементов в первой строке}

BEGIN

flag := FALSE; {Изначально допустим, что отриц.элементов нет}

 FOR i := 1 TO 10 DO

 FOR j := 1 TO 10 DO

 READLN (A[i, j]); {Заполняем массив элементами}

FOR i := 1 TO 10 DO

IF A[1, i] < 0 THEN flag := TRUE; {Проверяем первую строку на наличие отриц. элементов}.

IF flag THEN WRITELN ('Да') ELSE WRITELN ('Нет');

END.

Если в процессе понимания решения возникнут какие-либо сложности, то обращайтесь.



0,0(0 оценок)
Ответ:
оорог
31.01.2023 13:57
Основные свойства алгоритмов следующие:
1. Понятность для исполнителя — исполнитель алгоритма должен понимать, как его выполнять. Иными словами, имея алгоритм и произвольный вариант исходных данных, исполнитель должен знать, как надо действовать для выполнения этого алгоритма.
2. Дискpетность (прерывность, раздельность) — алгоpитм должен пpедставлять пpоцесс pешения задачи как последовательное выполнение пpостых (или pанее опpеделенных) шагов (этапов).
3. Опpеделенность — каждое пpавило алгоpитма должно быть четким, однозначным и не оставлять места для пpоизвола. Благодаpя этому свойству выполнение алгоpитма носит механический хаpактеp и не тpебует никаких дополнительных указаний или сведений о pешаемой задаче.
4. Pезультативность (или конечность) состоит в том, что за конечное число шагов алгоpитм либо должен пpиводить к pешению задачи, либо после конечного числа шагов останавливаться из-за невозможности получить решение с выдачей соответствующего сообщения, либо неограниченно продолжаться в течение времени, отведенного для исполнения алгоритма, с выдачей промежуточных результатов.
5. Массовость означает, что алгоpитм pешения задачи pазpабатывается в общем виде, т.е. он должен быть пpименим для некотоpого класса задач, pазличающихся лишь исходными данными. Пpи этом исходные данные могут выбиpаться из некотоpой области, котоpая называется областью пpименимости алгоpитма.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота