01.04.2020 05:36

Задания:

I.В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и

«/» — операции сложения, вычитания, умножения и деления. Правила и порядок

выполнения операций соответствуют правилам арифметики. Определите значение

переменной b после выполнения алгоритма:

1 Задание

а := 2

b := 4

а := 2*а + 3*b

b := a/2*b

В ответе укажите одно целое число — значение переменной b. (ответ: b= ).

2 Задание

Определите значение переменной b после выполнения алгоритма:

а := 5

b := 4

а := 2*а + 3*b

b := a/2*b

В ответе укажите одно целое число — значение переменной b.

2. Задание

Определите значение переменной b после выполнения алгоритма:

а := 4

b := 4

а := 2*а + 3*b

b := a/2*b

В ответе укажите одно целое число — значение переменной b.

3. Задание

Определите значение переменной b после выполнения алгоритма:

а := 6

b := 4

а := 2*а + 3*b

b := a/2*b

В ответе укажите одно целое число — значение переменной b.

4. Задание

Определите значение переменной b после выполнения алгоритма:

а := 7

b := 4

а := 2*а + 3*b

b := a/2*b

В ответе укажите одно целое число — значение переменной b.

ОТДЕЛЬНО Какие существуют виды данных?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
viktoriacotik1
31.05.2022 16:56

Население Тринидада и Тобаго весьма разнообразно по своему составу, что отражает историю развития страны. По оценкам на июль 2008 года численность населения государства составляла 1 231 323 человек.

Рост численности населения Тринидада и Тобаго во второй половине XX века

Первоначально острова были заселены индейцами. После начала колонизации индейцы были постепенно истреблены и ассимилированы европейскими поселенцами.

В течение трёх веков испанского владычества над Тринидадом остров заселялся очень медленно. В 1783 году население Тринидада составляло лишь около 2,8 тысяч человек, из них всего 126 европейцев. Именно в этот год Испания объявила выгодные условия для приобретения земли на острове для католиков. Это привело к тому, что за последующие 14 лет в колонию с других островов Вест-Индии переселилось большое количество французских плантаторов с рабами. Когда в 1797 году колония попала под власть британцев, население составляло уже около 20 000 человек (из них 2 000 европейцев). С 1830-х годов после отмены рабства на британских Карибских островах на Тринидад попадает большое количество рабочих из Индии.

0,0(0 оценок)
Ответ:
lilikykytik21
28.02.2022 22:26

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота