Shkolnikt
21.03.2022 23:56

Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка».

Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с команды copy и затем сложить их.

ма – copy (a,6,2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы)

Program slova;

Var a, b: string;

Begin a:=’информатика’;

b:= copy (a,6,2) + copy (a,5,1) + copy (a,10,2);

WriteLn (b);

End.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Schoolboy0770
13.10.2020 09:45

По идеи, строки в Паскале являются одномерными массивами, легче просто присвоить второй строке символы из первой строки:

b:= a[6]+a[2] ...

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота