Иленьк
26.06.2022 14:14

Написать программу по нахождению площадей фигур

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
WovenLion1
14.06.2021 01:11
Не самый лёгкий, но работающий

const  n = 10000;//Не изменяемая по ходу программы переменная
var  a: array[1..n] of integer;  b: array[1..10]of integer;  c: array[1..10]of integer;  i, s, v: integer;
begin  for i := 1 to 10 do //Заполнение массива с числами от 1 до 10    c[i] := i;  for i := 1 to n do //Заполнение массива    a[i] := random(10) + 1; //Делается для того чтобы в массиве не было нулей  for i := 1 to n do    case a[i] of      1: b[1] := b[1] + 1;      2: b[2] := b[2] + 1;      3: b[3] := b[3] + 1;      4: b[4] := b[4] + 1;      5: b[5] := b[5] + 1;      6: b[6] := b[6] + 1;      7: b[7] := b[7] + 1;      8: b[8] := b[8] + 1;      9: b[9] := b[9] + 1;      10: b[10] := b[10] + 1;    End;    for i := 1 to 10 do    for s := 1 to 9 do      if b[s] > b[s + 1] then begin        v := b[s];        b[s] := b[s + 1];        b[s + 1] := v;        v := c[s];        c[s] := c[s + 1];        c[s + 1] := v;      end;  writeln(c[10], ' - их ', b[10]);    end.
0,0(0 оценок)
Ответ:
ник5047
16.08.2021 07:21

Так, можем найти общие данные, которые нам в любом случае понадобятся для обоих пунктов:

I = 128 Кбайт = 1048576 бит

x = 640 * 320

Всё, теперь начинаем пункт а):

N = 16

N = 2^{i}

i = 4

Рассчитаем объем одной страницы:

I(1) = x * i = 640 * 320 * 4 = 819200 бит (объем 1 страницы)

Посмотрим сколько страниц влезет:

1048576 / 819200 = 1.28 = 1 страница (округляем в меньшую сторону, так как у нас тупо не хватит места, если мы округлим в большую)

Пункт б):

N = 256

N = 2^{i}

i = 8

I(1) = x * i = 640 * 320 * 8 = 1638400 бит (объём 1 страницы)

1048576 / 1638400 = 0.64 = 0 страниц (опять же, не хватит нашего объема для хранения даже 1 страницы)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота