Engee
23.12.2021 21:31

Г.
- . .
ит
Требовалось написать программу вычисления факториала числа п
(факториал числа песть произведение всех целых чисел от 1 до п).
Программист торопился и написал программу неправильно.
Ниже приведён фрагмент его программы, в котором содержится
пять ошибок:
k:=1;
f:=0;
while k<n do
f:=f*k;
k:=k+1
Найдите ошибки. Допишите необходимые операторы.
Пример входных данных
Введите n> 5
Пример выходных данных
5! = 120
6! = 720
Введите n> 6​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
/*Дан массив X(N,M) .Найти среднее арифметическое тех строк массива, первый элемент которых положительный*/#include <iostream>#include <time.h>#define M 5#define N 5using namespace std;
void printArray(int *mas, int n,int m)//инициализация и вывод массива { srand(time(0)); for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { *mas = rand() % 21-10; cout << *mas << "\t"; mas++; } cout << endl; }}

void srArray(int mas[][M], int n)//нахождение и подсчет тех строк, где первый элемент положительный{ int a; double sum = 0; for (int i = 0; i < n; i++) { double sr = 1; if (mas[i][0] > 0) { for (int j = 0; j < M; j++) { sum += mas[i][j]; } sr = sum / M; cout << "Ср элеменитов " << i + 1 <<  "-й строки = " << sr << endl; } else ; }
}

void main()//основная функция{ setlocale(LC_ALL, "rus"); int x[N][M]; printArray(&x[0][0], N, M); cout << endl; cout << ""<<endl; srArray(x, N); system("pause");}
0,0(0 оценок)
Ответ:
benten2434
01.01.2021 13:50
OCR-версия страницы из учебника (текст страницы, которая находится выше):Отсюда получаем ас = ab и Ьс = Ьа. Из этих двух равенств следует, что ас-Ьс, или (Ь - а) с = 0. Но Ь - а - АВ, с-DC, поэтомуАВ DC = 0, и, значит, АВ J_ CD, что и требовалось доказать.464    Вычислите угол между прямыми АВ и CD, если: а) А (3; -2; 4), В (4; -1; 2), С (6; -3; 2), D (7; -3; 1); б) А (5; -8; -1), В (6; -8; -2), С (7; -5; -И), D (7; -7; -9); в) А (1; 0; 2), В (2; 1; 0), С (0; -2; -4), D (-2; -4; 0); г) А (-6; -15; 7), В (-7; -15; 8), С (14; -10; 9), D (14; -10; 7).465    Дана правильная треугольная призма АВСА1В1С1, в которой ААХ = = л/2АВ (рис. 139, а). Найдите угол между прямыми АСХ и АХВ. РешениеПусть АВ = а, тогда ААХ = v2a. Введем прямоугольную систему координат так, как показано на рисунке 139, б. Вершины А, В, А1т С!имеют следующие координаты (объясните почему): А^~—;|-;0j,В (0; а; 0), А, ; j; aV2 ), С, (0; 0; aV2).Отсюда находим координаты векторов АСХ и ВАХ:ACi{-^#rf;aV2}, ^ ji^;-|;aV2Векторы АСг и ВАг являются направляющими векторами прямых ACj и AlB. Искомый угол ф между ними можно найти по фор-муле (2V    ,i_3a2+la2 + 2(J2!14 4    ,cos Ф = -    --------— = откуда Ф = 60°.;3a2+la2 + 2a2 . ;la2+la2 + 2a2 2\' 4 4    \ 4 4466    В кубе ABCDA^Bfi^D^ точка М лежит на ребре АА,, причем AM : MAj = 3 : 1, а точка N — середина ребра ВС. Вычислите косинус угла между прямыми: а) MN и DDX\ б) MN и BD; в) MN и В,£»; г) MN и Afi.
Как написать сочинение на 255 страница 119
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота