perminovdima20
22.04.2021 01:15

Тест Символьные строки
1. Какой тип данных используется в языке Паскаль для обозначения символьных строк?
ответ:
2. Отметьте все правильные объявления символьных строк.
var s: string;var string: s;vars, s1, s2: array[1..10] of char;
var s1, s2: integer;
var s, s1, s2: string;
3. Что будет выведено на экран после выполнения программы?
s := '123';
s := s + '0' + s;
s := s + s;writeln ( s );
ответ:
4. Что будет выведено на экран после выполнения этой программы?
s := '123';
s := s + s[2] + s + s[3];
writeln ( s );
ответ:
5. Что будет выведено на экран после выполнения этой программы?
s := '12345';
n := Length(s) + Length('456');
writeln ( n );
ответ:
6. Что будет выведено на экран после выполнения программы?
s := '123456789';
s1 := 'abcdef';
s := Copy(s,5,2) + '0' + Copy(s1,3,3);
writeln ( s );
ответ:
7. Что будет выведено на экран после выполнения этой программы?s := '123456';
q := 'abc';Delete ( s, 2, 3 );
Insert ( s, q, 2 );
writeln ( q );
ответ:
8. Что будет выведено на экран после окончания работы программы?s := '123456789';
Delete ( s, 1, 2 );
n := Pos ( '6', s );
writeln ( n );
ответ:
9. Что будет выведено на экран после выполнения этой программы?s := '123456789';
n := Pos ( '456', s);
Delete ( s, n+2, 3 );
writeln ( s );
ответ:
10. Сколько единиц будет выведено на экран?
s := '123456';
while Length(s) > 0 do beginDelete ( s, 1, 2 );
writeln ( '1' )end;
ответ:
11. Программа должна считать, сколько раз в строке S встречается подстрока'12'. Какой оператор надо вставить вместо многоточия? Вводите ответ без пробелов.
c := 0;
repeat
...
if p <> 0 then begin
c := c + 1;
Delete ( S, 1, p+1)
end;
until p = 0;
ответ:
12. Программа должна считать, сколько раз в строкеSвстречается цифра'0'. Какой оператор надо вставить вместо многоточия? Вводите ответ без пробелов.
c := 0;
for k:=1 to Length(S) do begin
if S[k] = '0' then
...
end;
ответ:
13. Какой оператор надо вставить вместо многоточия, чтобы в строке S были записаны символы строки Q в обратном порядке? Вводите ответ без пробелов.
Q := '123456789';
S := '1';
for k:=2 to 9 do begin
...
end;
ответ:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
K0Tiko
16.04.2020 00:30

ответ:Пиши в лс Объяснение:

0,0(0 оценок)
Ответ:
Nelly175
19.01.2024 10:08
1. В языке Паскаль для обозначения символьных строк используется тип данных "string".
Ответ: string.

2. Правильные объявления символьных строк:
- var s: string;
- var s, s1, s2: string;

Ответ: var s: string; и var s, s1, s2: string;

3. После выполнения программы будет выведено значение переменной s, которое будет равно '123012301230'.
Пояснение: В первой строке s присваивается значение '123'. Во второй строке s прибавляется '0' и s, что приводит к результату '12301230'. В третьей строке к s прибавляется s, в результате чего s будет '123012301230'.

Ответ: '123012301230'.

4. После выполнения программы будет выведено значение переменной s, которое будет равно '123213123'.
Пояснение: В первой строке s присваивается значение '123'. Во второй строке к s прибавляется s[2] (второй символ строки s), s и s[3] (третий символ строки s), что приводит к результату '123213123'.

Ответ: '123213123'.

5. После выполнения программы будет выведено значение переменной n, которое будет равно 11.
Пояснение: В первой строке переменной n присваивается значение суммы длины строки s (5) и длины строки '456' (3), что равно 8. Во второй строке выводится значение переменной n.

Ответ: 11.

6. После выполнения программы будет выведено значение переменной s, которое будет равно '678abc'.
Пояснение: В первой строке s присваивается значение '123456789'. Во второй строке s1 присваивается значение 'abcdef'. В третьей строке в переменную s копируются символы с 5-го по 2 символа и добавляются '0' и символы с 3-го по 3 символ строки s1, что приводит к результату '678abc'. В четвертой строке выводится значение переменной s.

Ответ: '678abc'.

7. После выполнения программы будет выведено значение переменной q, которое будет равно 'abc'.
Пояснение: В первой строке переменной s присваивается значение '123456'. Во второй строке переменной q присваивается значение 'abc'. В третьей строке из строки s удаляются 3 символа начиная с 2 позиции, затем в строку s вставляется строка q начиная с 2 позиции. В четвертой строке выводится значение переменной q.

Ответ: 'abc'.

8. После выполнения программы будет выведено значение переменной n, которое будет равно 6.
Пояснение: В первой строке переменной s присваивается значение '123456789'. Во второй строке из строки s удаляются 2 символа, начиная с первой позиции. В третьей строке переменной n присваивается позиция символа '6' в строке s, которая равна 6. В четвертой строке выводится значение переменной n.

Ответ: 6.

9. После выполнения программы будет выведено значение переменной s, которое будет равно '12378'.
Пояснение: В первой строке переменной s присваивается значение '123456789'. Во второй строке переменной n присваивается позиция подстроки '456' в строке s, которая равна 4. В третьей строке из строки s удаляются 3 символа, начиная с 6 позиции (n+2). В четвертой строке выводится значение переменной s.

Ответ: '12378'.

10. Будет выведено 3 единицы.
Пояснение: В цикле while происходит удаление первых двух символов строки s на каждой итерации, пока длина строки s больше 0. Таким образом, при первой итерации удаляются символы '12', при второй - '34' и при третьей - '56'. Таким образом, на экран будет выведено 3 единицы.

Ответ: 3.

11. Вместо многоточия нужно вставить оператор "p := Pos('12', S);".
Пояснение: В цикле repeat ищется позиция подстроки '12' в строке S. Если позиция найдена (p не равно 0), то увеличивается счетчик c на 1 и происходит удаление первых (p+1) символов из строки s. Цикл повторяется до тех пор, пока позиция подстроки '12' будет найдена. Когда позиция станет равна 0, цикл прекратится.

Ответ: p := Pos('12', S);

12. Вместо многоточия нужно вставить оператор "c := c + 1;".
Пояснение: В цикле for происходит перебор всех символов строки S. Если текущий символ равен '0', то счетчик c увеличивается на 1. В итоге будет подсчитано количество символов '0' в строке S.

Ответ: c := c + 1;

13. Вместо многоточия нужно вставить оператор "S := Q[k] + S;".
Пояснение: В цикле for происходит перебор всех символов строки Q. На каждой итерации символ строки Q добавляется в начало строки S. Таким образом, символы строки Q будут записаны в строку S в обратном порядке.

Ответ: S := Q[k] + S.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота