aleksey778
09.03.2023 00:08

составьте программу для чтения отрывка из текста.Переключение его на Перевертыш и передача его на печать в том же варианте. Слово перевертыша переводится следующим образом: буквы, стоящие до первого гласного, перемещаются до конца слова и соединяются с окончанием quot; циусquot;. Например.
a)" кот в сапогах " -- " откциус вциус апогахсциус"
b) "пример перевода" -- " имерпрциус ереводапциус"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Asig
13.10.2020 07:50

// PascalABC.Net

var vowel: set of char = ['а', 'у', 'о', 'ы', 'и', 'э', 'я', 'ю', 'ё', 'е'];

s, substr: string;

begin

  s := 'кот в сапогах';

  var words := s.Split(' ');

  for var i := 0 to words.length - 1 do

  begin

      for var j := 1 to words[i].Length do

          if words[i][j] in vowel then

          begin

              substr := Copy(words[i], 1, j-1);

              Delete(words[i], 1, j-1);

              words[i] += substr;

              break;

          end;

      words[i] += 'циус';

  end;

  writeln(words.JoinIntoString(' '));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота