rgfheh
22.01.2020 18:06

Составить программу, которая печатает столбик таблицы умножения натурального числа в десятичной системе счисления, вводимого с клавиатуры. Например, с клавиатуры вводится число 5, должно быть напечатано:

5*1=5

5*2=10



5*10=50.
паскаль абс

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Якивк
20.08.2020 08:11
№ 1-2

var x, t, f, l, sum, sum2: integer;
begin
write('Введите x: ');
readln(x);
if ( x < 10000 ) OR ( x > 99999 ) then
writeln('Ошибка. Число не пятизначное!')
else
begin
l := x mod 10;
t := (x div 1000 mod 10);
sum := l + t;
f := (x div 10 mod 10);
sum2 := t + f;
writeln('Сумма второй и последней цифры: ', sum);
writeln('Сумма второй и четвертой цифры: ', sum2);
end;
end.

№3

var a, b, c, rez: integer;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
rez := 0;
if a mod 2 = 0 then inc(rez);
if b mod 2 = 0 then inc(rez);
if c mod 2 = 0 then inc(rez);
writeln('Количество четных чисел: ', rez);
end.
0,0(0 оценок)
Ответ:
kdfrolova
13.02.2023 10:34
Var
    i, s1, s2, s3, s4, n: integer;

begin
    write('n = ');
    readln(n);
    s1 := 0;
    s2 := 0;
    s3 := 0;
    s4 := 0;
    
    for i := 1 to n do
    begin
        s1 := s1 + i;
        s2 := s2 + sqr(i);
        if i mod 2 = 0 then s3 := s3 + i;
    end;
    
    for i := 10 to 99 do s4 := s4 + i;
    
    writeln('Сумма первых n натуральных чисел: ', s1);
    writeln('Сумма квадратов первых n натуральных чисел: ', s2);
    writeln('Сумма всех четных чисел: ', s3);
    writeln('Сумма всех двухзначных чисел: ', s4);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота