tayteldiyev2005
25.04.2023 10:04

Ребят с программой уже 3 часа не могу её написать,

нужно написать программу которая будет решать алгебраическое уравнение 4 степени:

ax^4+bx^3+cx^2+dx+e

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
jdgdjrs
17.12.2021 20:28

var

 A: array [1..3, 1..5] of Integer;

 i, j: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := 1 to 3 do begin   // заполнение массива случайными значениями и вывод для просмотра

   for j := 1 to 5 do begin

     A [i, j] := Random (22) - 11;

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

 for i := 1 to 3 do begin   // замена элементов с четной суммой индексов на 555

   for j := 1 to 5 do begin

     if (i + j) mod 2 = 0 then

       A [i, j] := 555;

   end;

 end;

 WriteLn;

 WriteLn ('Результат: ');   // вывод результата

 for i := 1 to 3 do begin

   for j := 1 to 5 do begin

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

end.

0,0(0 оценок)
Ответ:
Вета2008
17.12.2021 20:28

var

 A: array [1..3, 1..5] of Integer;

 i, j: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := 1 to 3 do begin   // заполнение массива случайными значениями и вывод для просмотра

   for j := 1 to 5 do begin

     A [i, j] := Random (22) - 11;

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

 for i := 1 to 3 do begin   // замена элементов с четной суммой индексов на 555

   for j := 1 to 5 do begin

     if (i + j) mod 2 = 0 then

       A [i, j] := 555;

   end;

 end;

 WriteLn;

 WriteLn ('Результат: ');   // вывод результата

 for i := 1 to 3 do begin

   for j := 1 to 5 do begin

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота