akselroddasha
21.01.2022 22:45

По этим блок схемам написать программу на Кумире в тетради.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dasha555m
25.09.2020 22:37

Если тупо с паскаля перевести, то можно и без math обойтись ведь

x, y = map(int, input("Введите значения x и y: ").split())

if (x**2+y**2 <= 1) or (x<=0) and (y<=0) and (y>=-x-2):

   print("Точка попадает в область")

else:

   print("Точка не попадает в область")

Если исправлять твой код, то:

def formula():

   print ('Введите значения x и y:')

   x, y = map(int, input().split())

   print('x=',x, 'y=', y)

   if (x**2+y**2 <= 1) or (x<=0) and (y<=0) and (y>=-x-2):

       print(' Точка попадает в область! ')

   else:  

       print(' Точка не попадает в область !')

formula()

0,0(0 оценок)
Ответ:
rodoskinatanya
15.02.2020 10:07
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger(ReadInteger('n='));
  var b:=a.Distinct.OrderBy(x->x).ToArray; b.Println
end.

Пример
n= 7
3 -5 6 3 3 4 1
-5 1 3 4 6

begin
  var n1:=ReadInteger('Длина первого массива-');
  var c:=ReadSeqInteger('Вводите массив:',n1).OrderBy(x->x).ToArray;
  var n2:=ReadInteger('Длина второго массива-');
  var d:=ReadSeqInteger('Вводите массив:',n2).OrderBy(x->x).ToArray;
  //собственно слияние
  var f:=new integer[n1+n2];
  var (ic,id,&if):=(0,0,0);
  repeat
    if c[ic]<d[id] then begin f[&if]:=c[ic]; ic+=1 end
    else begin f[&if]:=d[id]; id+=1 end;
    &if+=1
  until (ic=n1) or (id=n2);
  if ic=n1 then
    repeat
      f[&if]:=d[id]; id+=1; &if+=1
    until id=n2
  else
    repeat
      f[&if]:=c[ic]; ic+=1; &if+=1
    until ic=n1;
  Write('Массив F: '); f.Println(',')
end.

Пример
Длина первого массива- 6
Вводите массив: 4 0 -3 6 4 2
Длина второго массива- 5
Вводите массив: 3 6 -3 0 2
Массив F: -3,-3,0,0,2,2,3,4,4,6,6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота