daniilznanija0
17.01.2020 02:54

написать программу PASCAL ( процедуры и функции)
Подсчитать произведение четных элементов одномерного массива вещественных чисел, стоящих на нечетных местах. В подпрограмме-процедуре заполнить массив случайным образом в диапазоне [-80;20], а в подпрограмме-функции подсчитать произведение четных элементов, стоящих на нечетных местах.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
amanullina
05.05.2020 02:14
Const dlin = 100;
var b:array[1..dlin,1..2] of integer;
      i,j,x:integer;
begin
writeln('Исходный массив:');
for i:=1 to dlin do
 begin
  b[i,1]:=random(800)+100;
  write(b[i,1],' ');
  b[i,2]:=b[i,1] mod 10 + b[i,1] div 100 + b[i,1] div 10 mod 10;
 end;
writeln;

for i:=1 to dlin-1 do
  for j:=dlin-1 downto i do
     if b[j,2]>b[j+1,2] then
     begin
      x:=b[j,2]; b[j,2]:=b[j+1,2]; b[j+1,2]:=x;
      x:=b[j,1]; b[j,1]:=b[j+1,1]; b[j+1,1]:=x;
     end;

writeln('Отсортированный массив:');
for i:=1 to dlin do
   write(b[i,1],' ');

end.
0,0(0 оценок)
Ответ:
bbb87
19.03.2020 13:27
var
  i, k, N: word;               
  A, B: array[1..10000] of integer;

begin 
  write(' N = ');
  readln(N);
  writeln(' Введите массив из ', N, ' чисел: ');
  for i := 1 to N do
  begin
    read(a[i]); //Вводим i-й элемент массива.
    if a[i] mod 2 = 0 then //Если он четный,  
    begin
      inc(K); //то увеличиваем K на 1.
      b[K] := a[i] //Очередной элемент нового массива.  
    end
  end;
  writeln('Четные числа обратном порядке: ');
 { Выводим четные элементы массива в обратном порядке: }
  for i := K downto 1 do
    write(' ', b[i]);
  write(' K = ', K)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота