hellooiooooooo
24.05.2021 19:55

Напишите программу которая получает пять чисел и выводит количество одинаковых чисел в этой цепочке ( ) Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Unikorn111
13.10.2020 06:07

var a: array [1..5] of integer;

i, j , count: integer;

repeated : boolean;

begin

   for i := 1 to 5 do

   begin

       write('Введите ', i, '-e число: ');

       readln(a[i]);

   end;

   for i := 1 to 5 do

   begin

       repeated := false;

       for j := 1 to i - 1 do

           if (a[i] = a[j]) then

               repeated := true;

       if repeated then continue;

       

       count := 1;

       for j:= i+1 to 5 do

           if (a[i]=a[j]) then

               inc(count);

       writeln('Число ', a[i], ' встречается ', count,' раз');

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота