человек9527
20.12.2022 17:47

Написать программу вычисления этих функций

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mottorinanadia7
07.02.2021 23:26
1.
var n,i:integer;
mass:array[1..10000] of integer;
begin
writeln('Введите кол-во чисел');
read(n);
for i:=1 to n do
begin
write('mass[',i,']=');
read(mass[i]);
end;
writeln('Элементы массива которые четные и двухначные');
for i:=1 to n do
if (mass[i] mod 2=0) and (mass[i] div 10>0) and (mass[i] div 10<10) then write(mass[i]:4);
end.
2.
var n,i:integer;
mass:array[1..10000] of integer;
begin
writeln('Введите кол-во чисел');
read(n);
for i:=1 to n do
begin
write('mass[',i,']=');
read(mass[i]);
end;
writeln('Элементы массива которые кратны 4 и трехзначные');
for i:=1 to n do
if (mass[i] mod 4=0) and (mass[i] div 100>0) and (mass[i] div 100<10) then write(mass[i]:4);
end.
3.
var i,a,m:integer;
begin
m:=3;
for i:=1 to 10 do
writeln(i,' * ',m,' = ',i*m);
end.
0,0(0 оценок)
Ответ:
tfdr
07.02.2021 23:26
Задание №1
var
  x:integer;
begin
  for x:=5 to 15 do Writeln('x=',x:2,'  y=',2*x)
end.

Результат выполнения программы:
x= 5  y=10
x= 6  y=12
x= 7  y=14
x= 8  y=16
x= 9  y=18
x=10  y=20
x=11  y=22
x=12  y=24
x=13  y=26
x=14  y=28
x=15  y=30

Задание №2
var
  x:real;
begin
  x:=1;
  while x<=2 do begin
    Writeln('x=',x:4:1,'   y=',sin(3*x):8:5);
    x:=x+0.3
  end
end.

Результат выполнения программы:
x= 1.0   y= 0.14112
x= 1.3   y=-0.68777
x= 1.6   y=-0.99616
x= 1.9   y=-0.55069

Задание №3
const
  n=40;
var
  i:integer;
  a:real;
begin
  for i:=1 to n do
  begin Write('a',i,'='); Read(a); Writeln('S=',sqr(a)) end
end.

Фрагмент работы программы:
a1=2.6
S=6.76
a2=4.18
S=17.4724
a3=1
S=1
a4=17
S=289
a5=
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота