Sharabyrin
23.12.2021 15:28

Составить программу, которая при вводе значения показывает, честно ли введенное значение. Диапазон вводимых данных от 1 до 100. Используя конструкцию CASE.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Demirline
13.10.2022 19:57

ответ:Решение

АЛГОРИТМ МАЛЕНЬКИЕ КВАДРАТЫ

алг квадраты_1

нач

   нц 5 раз

      опустить перо

      сместиться на вектор (2, 0)

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      сместиться на вектор (0, - 2)

      поднять перо

      сместиться на вектор (3, 0)

         опустить перо

         сместиться на вектор (1, 1)

         сместиться на вектор (- 1, 1)

         сместиться на вектор (- 1, - 1)

         сместиться на вектор (1, - 1)

      поднять перо

   кц

кон

АЛГОРИТМ БОЛЬШИЕ КВАДРАТЫ

алг квадраты_2

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (2, 0)

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      сместиться на вектор (0, - 2)

      поднять перо

      сместиться на вектор (4, - 1)

         опустить перо

         сместиться на вектор (2, 2)

         сместиться на вектор (- 2, 2)

         сместиться на вектор (- 2, - 2)

         сместиться на вектор (2, - 2)

      поднять перо

   кц

кон

АЛГОРИТМ ПРЯМОУГОЛЬНИКИ

алг прямоугольники_1

нач

   нц 5 раз

      опустить перо

      сместиться на вектор (0, 1)

      сместиться на вектор (- 3, 0)

      сместиться на вектор (0, - 2)

      сместиться на вектор (3, 0)

      сместиться на вектор (0, 1)

      

      сместиться на вектор (- 1, 0)

      сместиться на вектор (0, - 2)

      сместиться на вектор (3, 0)

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      поднять перо

      сместиться на вектор (4, 0)

   кц

кон

АЛГОРИТМ УЗОР

алг часть_1

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (0, 2)

      сместиться на вектор (2, 0)

      поднять перо

      сместиться на вектор (- 3, - 1)

   кц

кон

алг часть_2

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      поднять перо

      сместиться на вектор (3, - 1)

   кц

кон

алг часть_3

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (2, 0)

      сместиться на вектор (0, 2)

      поднять перо

      сместиться на вектор (- 1, - 3)

   кц

кон

алг часть_4

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (0, - 2)

      сместиться на вектор (2, 0)

      поднять перо

      сместиться на вектор (- 3, 1)

   кц

кон

использовать Чертежник

алг узор_1

нач

   часть_1

   сместиться на вектор (5, - 5)

   часть_2

   сместиться на вектор (- 3, - 7)

   часть_3

   сместиться на вектор (- 7, 3)

   часть_4

кон

АЛГОРИТМ УЗОР 2

использовать Чертежник

алг узор_2

нач

   часть_3

   сместиться на вектор (4, 3)

   часть_4

   сместиться на вектор (1, - 6)

   часть_1

   сместиться на вектор (- 9, 2)

   часть_2

кон

Объяснение:

0,0(0 оценок)
Ответ:
томкавеликая
08.09.2020 12:00
1)
begin
  var s1:=ReadlnString('Текст:');
  Writeln('k = ',s1.Where(c->Pos(c,'01')>0).Count);
  var s2:=s1.Select(c->c='0'?'A':c).Select(c->c='1'?'M':c);
  s2.Println;
end.

Пример:
Текст: Текст с 1 и 0: 110+101=1011
k = 12
Текст с M и A: MMA+MAM=MAMM

2)
var s1,s2:string;
i,k:integer;
begin
writeln('Введите текст:');
readln(s1);
k:=0;
s2:='';
for i:=1 to length(s1) do
 if s1[i]='0'
  then begin s2:=s2+'A'; k:=k+1; end
  else if s1[i]='1' then begin s2:=s2+'M'; k:=k+1; end else s2:=s2+s1[i];
writeln(s2);
writeln('k = ',k);
end.

Пример:
Введите текст:
Текст с 1 и 0: 110+101=1011
Текст с M и A: MMA+MAM=MAMM
k = 12
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота