Зонтик17
24.10.2020 14:10

Уровень A. Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл.(ошибка времени исполнения)

var
a, b, c: integer;
d: text;
begin
assign(d,'input.txt');
reset(d);
c:=0;
b:=0;
while not eof do
begin
readln(d,a);
c:= c + a;
b:= b + 1;
end;
close(d);
assign (d,'output.txt');
rewrite(d);
write(d,c/b);
close(d);
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Надеждаесть
11.09.2022 18:38

uses GraphABC;

begin

SetWindowWidth(600);

SetWindowHeight(500);

SetPenWidth (3);

Line(111,131,489,131);

Arc(300,200,200,160,380);

Pie(200,220,50,0,180);

Pie(400,220,50,0,180);

Pie(300,250,50,225,315);

Arc(300,320,50,180,360)

end.

Объяснение:

картинка

Будет ли работать у тебя точно не знаю.

У тебя, возможно, будет работать в таком виде:

uses GraphABC;

begin

SetWindowWidth(600);

SetWindowHeight(500);

SetPenWidth (3);

Chord(300,200,200,160,380);

Chord(200,220,50,0,180);

Chord(400,220,50,0,180);

Pie(300,250,50,225,315);

Arc(300,320,50,180,360)

end.

Эти строчки:

SetWindowWidth(600);

SetWindowHeight(500);

SetPenWidth (3);

можно выкинуть, если с ними будут проблемы (это просто размеры окна и толщина линии)


Измените программу так, чтобы маска улыбалась uses GraphABC;begin Chord(300,200,200,160,380);Chord(2
0,0(0 оценок)
Ответ:
ktoya2
10.08.2021 08:37

При построении классификации ПО нужно учитывать тот факт, что стремительное развитие вычислительной техники и расширение сферы приложения компьютеров резко ускорили процесс эволюции программного обеспечения.

Если раньше можно было по пальцам перечислить основные категории ПО — операционные системы, трансляторы, пакеты прикладных программ, то сейчас ситуация коренным образом изменилась.

Развитие ПО пошло как вглубь (появились новые подходы к построению операционных систем, языков программирования и т.д.), так и вширь (прикладные программы перестали быть прикладными и приобрели самостоятельную ценность).

Соотношение между требующимися программными продуктами и имеющимися на рынке меняется очень быстро. Даже классические программные продукты, такие, как операционные системы, непрерывно развиваются и наделяются интеллектуальными функциями, многие из которых ранее относились только к интеллектуальным возможностям человека.

Кроме того, появились нетрадиционные программы, классифицировать которые по устоявшимся критериям очень трудно, а то и просто невозможно, как, например, программа — электронный собеседник.

Объяснение:

Вроде так

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота