досметова
14.05.2023 12:32

Решите нужно написать программу перемещения робота по лабиринту за минимальное кол-во шагов ( программа для программирования кумир)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
9Единорожка1111111
15.04.2021 17:37
// PascalABC.NET 3.2, сборка 1400 от 13.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  var m:=a.Min;
  var b:=a.Where(x->x<>m); b.Println;
end.

Пример
n= 30
-3 6 -2 5 -1 -10 3 9 8 5 2 9 4 -10 8 10 6 9 -8 4 -7 2 10 -7 -7 -5 1 2 0 -3
-3 6 -2 5 -1 3 9 8 5 2 9 4 8 10 6 9 -8 4 -7 2 10 -7 -7 -5 1 2 0 -3

С процедурами и функциями (высосано из пальца, ибо не нужно)
// PascalABC.NET 3.2, сборка 1400 от 13.03.2017
// Внимание! Если программа не работает, обновите версию!

function ArrMin(a:array of integer):=a.Min;

procedure NewSequence(a:array of integer; del:integer; var s:sequence of integer);
begin
  s:=a.Where(x->x<>del)
end;

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  var b:sequence of integer;
  NewSequence(a,ArrMin(a),b);
  b.Println
end.
0,0(0 оценок)
Ответ:
TokstoyLev
17.01.2021 05:23
1)
procedure Insert(source: string; var s: string; index: integer); 
        Вставляет подстроку source в строку s с позиции indexprocedure Delete(var s: string; index, count: integer); 
        Удаляет из строки s count символов с позиции index

2)
var s:string; i,n,code:integer;
begin
write('Введите длинное число:');
readln(s);
for i:=1 to length(s) do
 begin
 val(s[i],n,code);
 if code=0 then writeln(n);
 end;
end.

Пример:
Введите длинное число:3456810285
3
4
5
6
8
1
0
2
8
5

Если не требуется выполнять арифметических действий с цифрами, то можно так:
var s:string; i:integer;
begin
write('Введите длинное число:');
readln(s);
for i:=1 to length(s) do writeln(s[i]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота