Войти
Регистрация
Спроси ai-bota
nomar
15.11.2022 21:49
По блок схеме, составить программу сделать задание, по информатике.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
vetoss2
18.08.2020 13:14
Мемлекетти жане онын курылуынын тарихи манызын матинен аныктаныз Тжб отинем айтындарш ...
Polybel
20.04.2020 18:40
В ваш класс пришли три новичка: Иванов, Петров и Сидоров. Каждый из них занимается в двух секциях. Секции : футбол, волейбол, шахматы, баскетбол, хоккей, биатлон. Известно,...
LisenokLove2003
27.03.2023 20:45
На рисунке представлено генеалогическое дерево Ивана,где отмечены одни мужчины.Информатика 9...
Мозг66615
25.06.2021 06:48
Створити проект для обчислення відстані яку проїхав автомобіль за формулою S = в * т інформатика...
llleeennn
03.01.2020 23:12
Размер файла 50 Мб. Сколько секунд займет передача этого файла, если скорость передачи 25 килобайт/с ?...
IsabellaSwan2017
15.04.2023 09:27
с информатикой К какому разделу компьютерной графики относятся графика, отображающая результаты какой-либо сфере деятельности?А) конструктторская графикаб) компьютерная анимацияв)...
larson6909
07.04.2021 05:36
Найти среднее геометрическое двух чисел. На языке С(Си)...
ArtGame23
06.05.2022 11:07
Установите соответствие: вставка из буфера отмена команды вывод контекстной справки 1)Esc 2)F1 3)Ctrl+V...
Ljjr6958der8cox45
30.09.2021 01:04
Написать программы с циклами...
артем200412прков
03.03.2021 07:10
Скласти 7 речень про свою матусю....
Ответ:
marisa10
26.11.2021 09:33
[l,r,строка,номер]
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[0, 3, "abba", 5]
[3, 3, "a", 6]
[3, 4, "aa", 7]
[4, 4, "a", 8]
[3, 5, "aaa", 9]
[4, 5, "aa", 10]
[5, 5, "a", 11]
[3, 6, "", 12]
[4, 6, "aaa", 13]
[5, 6, "aa", 14]
[6, 6, "a", 15]
[2, 7, "bb", 16]
[7, 7, "b", 17]
[6, 8, "aba", 18]
[8, 8, "a", 19]
[7, 9, "bab", 20]
[9, 9, "b", 21]
#код программы Ruby 22
s = "abbbab"
n = 0
for r in 0..s.size-1
for l in 0..r
t = s[l..r]
if t.reverse == t
n += 1
p [l,r,t,n]
end
end
end
0,0
(0 оценок)
Ответ:
vlada363
16.03.2020 21:38
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота