rhbyf
19.01.2021 23:47

Определите значение задан. программы Vari,S: integer; Begin S:=0; For i:=1 to 10 do S:=S+i; Write(‘S=’,S); End.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
русскийязык150
03.07.2021 04:28

достоинства растровой графики:  

растровая графика предоставляет возможность создавать любые изображения не обращая внимание на сложность их исполнения в отличие от векторной графики, которая неспособна предать хорошо переход цветов от одного к другому.

широкий спектр применения – растровая графика на сегодняшний день нашла широкое применение в различных областях, от мелких изображений (иконок) до крупных (плакатов).

высокая скорость обработки изображений различной сложности, при условие что нет необходимости в их масштабирование.

представление растровой графики является естественным для большинства устройств и техники ввода-вывода графики.

недостатки растровой графики:

большой размер файлов с простыми растровыми изображениями.

невозможно увеличение изображения в масштабе без потери качества.

вывод изображения при печати на плоттер является затруднительным.

при хорошем качестве изображения требуются значительный объем дискового пространства для хранения файлов.

сложность преобразования растрового изображения в векторное.

исходя из вышеуказанных недостатков хранить простые рисунки рекомендуется не в сжатой растровой графике, а использовать векторную.

достоинства векторной графики:

масштабирование размеров без потери качества изображения.

масштабированные изображения не увеличиваются в весе ни на один байт.

во время масштабирования качество, резкость, четкость и цветовые оттенки изображений не .

вес изображения в векторном формате в разы меньше веса изображения в растровом формате.

при конвертации изображения из векторного формата в растровый, не возникает никакой сложности.

толщина линий при изменение масштаба (увеличение или уменьшение) объектов может не изменяться.

недостатки векторной графики:

в векторной графике можно изобразить далеко не каждый объект. объем памяти и интервал времени на отображение векторной графики зависит от количества объектов и их сложности.

после преобразование из растрового изображения в векторное, обычно качество векторного изображения не высокое.

я думаю она нужна.

0,0(0 оценок)
Ответ:
Софья3601
02.04.2020 19:36
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    cout << "Enter size of array: ";
    int N;
    cin >> N;
    int * ARR = new int[N];
    srand(time(0));
    int i;
    for (i = 0; i < N; ++i)
        ARR[i] = rand() % 100 + 1;

    cout << "Here is an original array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    int temp = ARR[N - 1];
    for (i = N - 1; i > 0; --i)
        ARR[i] = ARR[i - 1];
    ARR[0] = temp;

    cout << "\nHere is a new array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота