mariyavlasova2
22.11.2022 01:57

Написать программу, которая будет принимать на ввод массив из n целочисленных элементов, а потом будет заполнять его случайными числами от 1 до 100 и выводить на экран. Значение n вводиться с клавиатуры и не должно превышать 50

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Fivesecond
25.06.2022 21:51
Вопрос №1:   1) - г                       2) - а                       3) - б                       4) - д                       5) - в вопрос №2: 1) - б                       2) - в                       3) - а                       4) - д                       5) - г вопрос №3: в,г вопрос №4: для ответа на этот вопрос необходимы картинки из условия, так что ответить без них не представляется возможным. вопрос №5: в вопрос №6: д вопрос №7: 1) - г                       2) - в                       3) - а                       4) - д                       5) - б вопрос №8: 1) - б                       2) - а                       3) - в вопрос №9: здесь,как и в вопросе №4 решающую роль играет рисунок,которого нет - ответа без него быть не может. вопрос №10: а,б,д вопрос №11: в -  информационные компьютерные технологии с одновременным использованием нескольких видов информации.вопрос №12: все 3 варианта ответа имеют место быть верными, то есть все варианты верны.
0,0(0 оценок)
Ответ:
vikonil
14.11.2022 00:25

Объяснение:

const nmax=15;

var a:array[1..nmax,1..nmax] of integer;

m,n,i,j,k,x,y:integer;

begin

randomize;

repeat

write('Количество строк до ',nmax,' n=');

readln(n);

until n in [1..nmax];

repeat

write('Количество столбцов до ',nmax,' m=');

readln(m);

until m in [1..nmax];

k:=-1;

for j:=1 to m do

begin

y:=1;

x:=j;

while(x>0) and(y<=n) do

begin

k:=k+1;

a[y,x]:=k;

x:=x-1;

y:=y+1;

end;

end;

for j:=2 to n do

begin

y:=j;

x:=m;

while(x>0)and(y<=n) do

begin

k:=k+1;

a[y,x]:=k;

x:=x-1;

y:=y+1

end;

end;

for i:=1 to n do

begin

for j:=1 to m do

write(a[i,j]:4);

writeln

end;

readln

end.

Переведите на Питон, в Паскале давно не работал

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота