adrianaartus8
12.11.2020 12:26

• 1)Задан целочисленный массив a. Написать программу, которая ищет максимальный элемент в массиве и выводит на экран его номер. Обратите внимание не значение, а номер элемента в массиве.
• 2)Задан целочисленный массив arr[40] . Найти количество элементов массива, которые по модулю меньше произвольного наперед заданного числа. Вывести количество таких элементов в массиве.
• 3)Составьте функцию, которая по заданному массиву определяет, есть ли в массиве хотя бы один отрицательный элемент.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
530Саша1111
31.08.2020 00:41

Program Scheme;

Var xn,xk,dx,x,s,p,k,y: Extended;

Label rep;

Begin

write('Enter xn: ');

readln(xn);

write('Enter xk: ');

readln(xk);

write('Enter dx: ');

readln(dx);

s:=0; p:=1; x:=xn; k:=0;

rep:

If x <= xk then

 Begin

  y:=exp(sin(x))*cos(x);

  writeln('x = ',x:0:3, '  y = ', y:0:3);

  if y >= 0 then

  s:=s+y;

  if y <> 0 then

  p:=p*y;

  x:=x+dx;

  goto rep;

 End

else

 Begin

  writeln('S = ', s:0:3, ' P = ', p:0:3, ' k = ', k:0:3);

  exit;

 End;

End.

Объяснение: Если есть вопросы, пишите в лс.

0,0(0 оценок)
Ответ:
evbarseguan
04.06.2022 19:22
Сначала немного теории.
Тут у нас импликация(если..то...), комбинированная с конъюнкцией(и).
Таблица истинности импликации(стрелочки):
0 0 1
0 1 1
1 0 0
1 1 1
Общее правило: если a<=b, тогда правда
Таблица истинности конъюнкции(/\):
0 0 0
0 1 0
1 0 0
1 1 1
Общее правило: если есть одна ложь-всё ложь
Теперь о примере:
Просто подставляем вместо x варианты. Так как между двумя скобочками с Если... То... стоит И, нам нужен вариант, где оба Если... То... являются правдой.
Рассмотрим подробно 1 вариант:
21<25 - это правда
21<23 - это правда
Таким образом, в первых скобочках правда, это доказывает таблица истинности, приведённая выше.
21<22 - это правда
21>21 - это ложь
В этих скобочках-ложь.
А так как ложь и правда в И являются ложью, нам не подходит данный вариант
2 вариант-верный ответ, т.к.:
22<25 - это правда
22<23 - это правда
В первых скобочках правда
22<22 - это ложь
22>21 - это правда
И в этих скобках правда.
Как можно убедится, снова взглянув в таблицу истинности для конъюнкции, всё выражение является правдой.
3 и 4 посмотрите сами и убедитесь что это ложь.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота