dinafait2001
19.01.2022 04:09

Все программы должны быть на базе Python
1. Напишите программу, которая считает среднее число шагов при двоичном поиске для массива из 32 элементов в диапазоне 0 100. Для поиска используйте 1000 случайных чисел в этом же диапазоне.
2. Напишите программу, которая сортирует массив, а затем находит максимальное из чисел, встречающихся в массиве несколько раз.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alpengold1310
12.06.2021 05:15
Задание 5

program SumSeq;

 

{$APPTYPE CONSOLE}

 

uses

  SysUtils;

//const m:Integer  ;

var

  i, j, m, s:Integer;

  n: array of Integer;

begin

  s:=0;

  Writeln(m);

  Writeln('vvedite m');

  Readln(m);

  SetLength(n,m);

  for i:=0 to m do

    begin

      j:=Random(10);

      if j<5

         then n[i]:=-1*j

         else n[i]:=j;

      write(n[i], ' ')

    end;

  Writeln;

  Writeln('To continue push >>ENTER');

  Readln;

 

  for i:=0 to m do

    begin

      if n[i]<0

        then s:=s+sqr(n[i])

    end;

   writeln('s=',s);

   readln

 

 

  { TODO -oUser -cConsole Main : Insert code here }

end.

0,0(0 оценок)
Ответ:
пидрила5
12.06.2021 05:15
Задание 4
program months;
{$APPTYPE CONSOLE}
uses  SysUtils;var  i:Integer;begin  Write ('Vvedite nomer mesyaca');  Writeln(i);  Readln(i);
  case i of   1: Writeln ('January-1,2,3,4,5,6,7,8');   2: Writeln ('February-22,23');   3: Writeln ('March-8');   4: Writeln ('April-net');   5: Writeln ('May-1,8,9');   6: Writeln ('June-12');   7: Writeln ('July-net');   8: Writeln ('August-net');   9: Writeln ('September-net');   10:Writeln ('October-net');   11:Writeln ('November-4,5,6');   12:Writeln ('December-net');   end;   Readln
  { TODO -oUser -cConsole Main : Insert code here }end.
Там даты (номера) праздничных дней можете подправить, как вам надо!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота