kapysta123
05.12.2021 17:01

Информатика 8 класс
Ребята у меня осталось 15 минут(
Напишите программу, вычисляющую значение функции:
10*x - 3,если X > или = 5
Y=
X/2 + 12 , если X < 5

И второе

-100, если x < 0
Y = 0,если x > 0
100, если X >0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Mihan4ik
19.03.2021 11:58
//PascalABC.NET версия 3.3.5.1636 от 10.03.18
//Если программа не запускается, то обновите версию

const
    handsfree = true;
    nmax = 100;
    random_min = -28;
    random_max = 27;

var
    a: array[1..nmax] of integer;
    i, n, j, count: integer;
    mini, maxi: integer;
    min, max: real;
    temp: real;
    sum, product, harmonic: real;
    k: integer;

begin
    {ввод массива}
    n := nmax;
    if handsfree then
        n := random(nmax - 5) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(random_max - random_min) + random_min;
            write(a[i], ' ');
        end
        else
            readln(a[i]);
    end;
    writeln();
    
    {подсчет суммы и произведения и агригатов и кол-ва}
    sum := 0;
    product := 1;
    for i := 1 to n do
    begin
        sum := sum + a[i];
        if a[i] mod 3 = 0 then {если нужен фильтр}
            product := product * a[i];
    end;
    writeln('1) sum = ', sum);
    writeln('2) product = ', product);
    
    {подсчет суммы и произведения и агригатов и кол-ва}
    sum := 0;
    count := 0;
    for i := 1 to n do
    begin
        if i mod 2 = 1 then {если нужен фильтр}
        begin
            count := count + 1;
            sum := sum + a[i];
        end;
    end;
    writeln('3) average (selected) = ', sum / count);
    
    {подсчет суммы и произведения и агригатов и кол-ва}
    sum := 0;
    product := 1;
    count := 0;
    for i := 1 to n do
    begin
        if i mod 2 = 0 then {если нужен фильтр}
            sum := sum + a[i];
        if a[i] < 0 then {если нужен фильтр}
            product := product * a[i];
        if a[i] mod 2 = 1 then {если нужен фильтр}
            count := count + 1;
    end;
    writeln('4) count = ', count);
    writeln('4) sum = ', sum);
    writeln('4) product = ', product);
end.
0,0(0 оценок)
Ответ:
1) var n,a,kol,sum,i:int64;
begin
read(n);
for i:=1 to n do begin
   read(a);
   if (i mod 2)=1 then begin
                       inc(sum,a);
                       inc(kol);
                       end;
   end;
writeln(sum/kol);
end.
2)var n,a,kol,sum,i,pr:int64;
begin
read(n);
for i:=1 to n do begin
   read(a);
   if (i mod 2)=0 then begin
                       inc(sum,a);
                       end;
   if a<0 then pr:=pr*a;
   if (a mod 2)=1 then inc(kol);
   end;
writeln(sum,' ',pr,' ',kol);
end.
3) var ma,n,a,i:int64;
begin
read(n);
for i:=1 to n do begin
   read(a);
   if (a>ma) then begin
                  ma:=a;
                  end;
   end;
writeln(ma);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота