Мария1111121
13.03.2021 22:37

После прочтения теоритической части по теме "Программирование циклов с заданным условием продолжения работы" рассмотрите блок-схемы 1 и 2.

На блок-схему 1 написана программа на языке Паскаль.

program a_1;
var x, y: integer;
begin
writeln('введите два числа: x и y');
readln(x, y);
while (x>=1) and (y>=1) do
begin
x:=x div y;
y:=y-2;
end;
writeln (x);
writeln (y);
end.

Задания:

1. Набирите эту программу с программы Pascal ABC и узучите ответы.

2. Рассмотрите блок-схему 2 и напишите программу используя Pascal ABC.

3. Что будет выдавать программа, если при вводе х=6, y=8.

4. Что будет выдавать программа, если при вводе х=,1 y=0.

ответы записывайте через пробел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
гвст
03.06.2023 14:46

а) for, так как наша переменная, которая будет управлять циклом(как принято i ) будет принимать значения от 0 до 9, если начинать цикл с 0. Мы создаем переменную result и помещаем внутри цикла следующее выражение: result += 1/(i + 1). На выходе получим результат данного выражения.

б) В данном случае, можно использовать либо for range based, где выражение цикла выглядит так for (const auto & grade : grades), либо while с условием пока не дойдем до конца списка, зависит какой вид списка мы используем. Я считаю больше подходит for.

в) Думаю for range-based, либо обычный for.

г) ответ как и в б, можно использовать либо for ranged base, либо while, если значения аргументов содержатся в массиве, то тогда for range-based. Если например, тестирование происходит с пользовательского ввода, то тогда удобнее было бы использовать while.

0,0(0 оценок)
Ответ:
Abdresh
10.02.2023 09:26
Допустим число 123. Нам нужно найти первое, второе и третье его число.
То есть 1,2,3. потом их сложить или перемножить.
Чтобы найти первое число нужно 123 разделить на 100,получиться 1.23,его мы округляем и получаем 1.
Второе мы находим деля 123 на 100,получаем остаток 23, делим остаток на 10 и получаем 2.
Третье число мы находим деля 123 на 10 и получаем остаток.
Потом складываем их или перемножаем.
Пример на  pascal:
//div это делить,mod отстаток
var a,b,c,s: integer;
begin
Write('Введи число: ');
Read(s);
a:= s div 100;
b:= s mod 100 div 10;
c:= s mod 10;
WriteLn('Сумма: '+a+b+c);
WriteLn('Произведение: '+a*b*c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота