SmilLl
03.02.2020 12:27

(Python)
Напишите программу, которая спрашивает день рождения пользователя в формате ДД/ММ/ и выводит сообщение:
Вы родились в году, Д МММ.
Вместо выведите год, Д - день без ведущего нуля, МММ - название месяца в родительном падеже. Например, если пользователь ввёл 02/12/1985, то вывод будет:
Вы родились в 1985 году, 2 декабря.
Указания:
Используйте форматирование дат для чтения даты и вывода года и дня.
Напишите функцию, которая по номеру месяца вернёт правильное название месяца и используйте её для вывода месяца.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
спартак371
24.07.2020 06:55
Const n=5;
var 
a:array[1..n,1..n] of integer;
b:array[1..n] of integer;
i,j,max,min,s:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
   a[i,j]:=random(21);
   write(a[i,j]:4);
  end;
  writeln;
 end;
max:=a[1,n];
for i:=2 to n do
  if a[i,n-i+1]>max then max:=a[i,n-i+1];
writeln('1. max = ',max);
for i:=1 to n do
 begin
 min:=a[i,1];
 for j:=2 to n do
  if a[i,j]<min then min:=a[i,j];
 b[i]:=min;
 end;
s:=0;
writeln('2. Массив B');
for i:=1 to n do 
 begin
 write(b[i]:4);
 s:=s+b[i];
 end;
writeln;
writeln('3. среднее = ',s/n);
for i:=1 to n do 
 if b[i]>s/n then write(b[i]:4);
writeln;
end.

Пример:
Исходный массив:
  10  19  15  17  10
  12  12  10   1   5
  17   8   8  14  15
  12  11   8   0  13
   2   2   4  10   6
1. max = 11
2. Массив B
  10   1   8   0   2
3. среднее = 4.2
  10   8
0,0(0 оценок)
Ответ:
SerStroka
16.09.2021 20:07
#include <stdio.h>#include <stdlib.h>#include <string.h>#include <locale.h>
//Максимальная длина вводимой строки#define Mx_s 255
//Массив символов, которые //необходиом удалить в начале и конце строкиchar sim[] = { '\t', ' '};//Функция проверяющая входит ли данный символ c в массив simint char_in_arr(char c) { int f = 0; for (int i = 0; i < strlen(sim); i++) { if (c == sim[i]) { f = 1; break; } } return f;}

int main(){ setlocale(LC_ALL, "rus"); //Вводимая строка char s[Mx_s]; //Ввод данных printf("\n >> Введите строку\n <<"); fgets(s, Mx_s, stdin); int l = strlen(s) - 1; //Переменные для определения отсечений в начале и конце строки int pos_b = 0; int pos_e = l-1; //Проверяем начало строки //Если нам попадаются удаляемые символы то увеличиваем значение pos_b for (;(pos_b < l) && char_in_arr(s[pos_b]); pos_b++) {}
//Проверяем конец строки //Если нам попадаются удаляемые символы то уменьшаем значение pos_e for (;(pos_e >= 0) && (char_in_arr(s[pos_e])); pos_e--) {}
//Длина отсеченного отрезка int l2 = pos_e - pos_b + 1; //Если длина корректа то if (l2 > 0) { //Строка для результата char s2[Mx_s];
//Идем по строке s1 int pos = 0; for (int i = pos_b, k_s = 0; i <= pos_e; i++) { //Считаем пробелы, идущие подряд if (s[i] == ' ') k_s++; else k_s = 0;
//Если это не подряд идущие пробел if (k_s < 2) { //записываем символ в s2 s2[pos] = s[i]; pos++; } } s2[pos] = '\0';
//Вывод результат printf("\n >> Результат\n <<"); fputs(s2,stdout); } else //Строка пуста/Содержит только символы из массива sim printf("\n >> Ошибка в строке\n");
system("pause>>void"); return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота