2006лера
13.07.2020 04:25

Напишите программу в паскаль и 3 задачу

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vandannc
10.01.2020 19:04
Вот: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 const   n=5; var   a: array[1..n,1..n] of integer;   i,j,s: integer; begin   s: =0;   randomize;   for i: =1 to n do     begin       for j: =1 to n do         begin           a[i,j]: =random(10);           write(a[i,j]: 4);           if (i+j) mod 3=0 then             s: =s+a[i,j];         end;       writeln;     end;   writeln('s=',s); end.
0,0(0 оценок)
Ответ:
Опаснаятётя01
16.08.2021 14:35
// PascalABC.NET 3.0, сборка 1073
const
  m=5;
  n=4;
  a:array[1..m] of real=(2,-7.1,3.2,-5.4,6.9);
  b:array[1..n] of real=(8.1,3.2,-6.4,-3.5);
  k=3;
var
  i,j:integer;
  sk:real;
  s:array[1..m,1..n] of real;
begin
  Writeln('Массив S');
  for i:=1 to m do begin
    for j:=1 to n do begin
      s[i,j]:=a[i]*b[j];
      Write(s[i,j]:7:2)
    end;
    Writeln
  end;
  sk:=0;
  for i:=1 to m do sk:=sk+s[i,k];
  Writeln('Сумма элементов столбца ',k,' равна ',sk)
end.

Результат выполнения программы:
Массив S
  16.20   6.40 -12.80  -7.00
 -57.51 -22.72  45.44  24.85
  25.92  10.24 -20.48 -11.20
 -43.74 -17.28  34.56  18.90
  55.89  22.08 -44.16 -24.15
Сумма элементов столбца 3 равна 2.56
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота