Nastia2047
21.01.2022 17:01

Написать рекурсивный алгоритм в паскале.
Алгоритм вычисления функции F(n) задан следующими соотношениями:

F(n) = –n при n < 0

F(n) = 2n + 1 + F(n–3), если n чётно,

F(n) = 4n + 2·F(n–4), если n нечётно.

Чему равно значение функции F(33)?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
matyushin06
08.07.2020 20:39

задача 1.

var

   a, s : integer;

begin

   writeln('введите числа:');

   while s < 101 do begin

       read(a);

       s += a;

   end;

   writeln('Стоп! Сумма чисел больше 100, s=', s);

end.

задача 2.

var

   h : char;

   n : integer;

begin

   writeln('введите символы:');

   while n < 5 do begin

       read(h);

       if h = 'F' then n += 1;

   end;

   writeln('Стоп! Символ F был введен 5 раз')

end.

задача 3.

var

   a : integer;

begin

   write('Введите число от 1 до 4 : ');

   readln(a);

   if (a = 1) or (a = 2) then begin

       for var i := 3 downto 1 do begin

           for var j := 1 to i do write('*');

           writeln;

       end;

   end

   else if (a = 3) or (a = 4) then begin

       for var i := 1 to 3 do begin

           for var j := 1 to i do write('*');

           writeln;

       end;

   end

   else writeln('вы ввели не правильное число :(');

end.

0,0(0 оценок)
Ответ:
sonya19970
11.04.2020 07:12

использовать Чертежник

алг

нач

опустить перо

сместиться в точку (0,100)

сместиться в точку (200,300)

сместиться в точку (300,200)

сместиться в точку (300,100)

сместиться в точку (200,100)

сместиться в точку (200,0)

сместиться в точку (100,0)

сместиться в точку (200,-100)

сместиться в точку (100,-200)

сместиться в точку (0,-100)

сместиться в точку (0,-200)

сместиться в точку (0,200)

сместиться в точку (0,100)

сместиться в точку (-200,300)

сместиться в точку (-300,200)

сместиться в точку (-300,100)

сместиться в точку (-200,100)

сместиться в точку (-200,0)

сместиться в точку (-100,0)

сместиться в точку (-200,-100)

сместиться в точку (-100,-200)

сместиться в точку (0,-100

кон

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота