lalka137
07.09.2021 05:10

Напишите программу вычисления выражения: s= x в степени 3 + x в степени 5 + x в степени 7, где x и n
вводятся вручную. Используйте подпрограмму вычисления степени.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
usimbekovameruert
19.07.2021 03:49

Код:

def vejliv(s):

   return s + " "

print(vejliv(input('Предоставьте ввод...\n')))

Объяснение:

Примечание:

Что могу сказать! Очень странная функция. Содержит одну ошибку TypeError и, по моему мнению, две логических) Считаю необходимостью из-за синтаксической ошибки не следовать заданию и немного изменить функцию.

def vejliv(s):

   return s + " "

Изменение 1:

Был запрос на ввод параметра s, после чего этот параметр сразу переопределялся, что очень странно. Я убрал переопределение.

Изменение 2:

К переменной s была попытка прибавить метод print() ... :D

Метод удалён из этого места.

Изменение 3:

Удалено двойное прибавление s. Действие не соответствует условиям задачи выше функции.

Использование функции:

print(vejliv(input('Предоставьте ввод...\n')))

0,0(0 оценок)
Ответ:
kostenkoulana7
03.05.2023 17:22

П О Н Я Т И Е:

Толковый словарь русского языка Ожегова приводит 2 определения слова «информация»:

Сведения об окружающем мире и протекающих в нем процессах, воспринимаемые человеком или специальным устройством.

Сообщения, осведомляющие о положении дел, о состоянии чего-нибудь. (Научно-техническая и газетная информации, средства массовой информации — печать, радио, телевидение, кино).

Информация и ее свойства являются объектом исследования целого ряда научных дисциплин, таких как теория информации (математическая теория систем передачи информации), кибернетика (наука о связи и управлении в машинах и животных, а также в обществе и человеческих существах), семиотика (наука о знаках и знаковых системах), теория массовой коммуникации (исследование средств массовой информации и их влияния на общество), информатика (изучение процессов сбора, преобразования, хранения, защиты, поиска и передачи всех видов информации и средств их автоматизированной обработки), информодинамика (наука об открытых информационных системах), информациология (наука о получении, сохранении и передаче информации для различных множеств объектов) и т. д.

В информатике наиболее часто используется следующее определение этого термина:

Информация — осознанные сведения об окружающем мире, которые являются объектом хранения, преобразования, передачи и использования.

С В О Й С Т В А:

С точки зрения информатики наиболее важными представляются следующие общие качественные свойства: достоверность, полнота, точность, актуальность, полезность, ценность, своевременность, понятность, доступность, краткость и пр.

1) Объективность информации. Информация в любом своём проявлении объективна, она отображает объективную действительность. Например фраза "На улице тёплая погода" означает, что человек её произнесший считает погоду на улице тёплой, т.е. информацией в данном случае будет являться то, что определённый человек произнёс фразу следующего содержания.

2) Достоверность информации. Информация достоверна, если она отражает истинное положение дел. Достоверная информация принять нам правильное решение. Недостоверной информация может быть по следующим причинам:

-преднамеренное искажение (дезинформация) или непреднамеренное искажение субъективного свойства;

-искажение в результате воздействия помех («испорченный телефон») и недостаточно точных средств ее фиксации.

3) Полнота информации. Информацию можно назвать полной, если ее достаточно для понимания и принятия решений. Неполная информация может привести к ошибочному выводу или решению.

4) Точность информации определяется степенью ее близости к реальному состоянию объекта, процесса, явления и т. п.

5) Актуальность информации — важность для настоящего времени, злободневность, насущность. Только вовремя полученная информация может быть полезна.

6) Полезность (ценность) информации. Полезность может быть оценена применительно к нуждам конкретных ее потребителей и оценивается по тем задачам, которые можно решить с ее

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота