pumpus
03.08.2020 20:10

Напишите программу покупателю подсчитать заранее общую
стоимость необходимых материалов (паркет и обои) для ремонта в квартире.
Стоимость материалов по умолчанию за 1 квадратный метр а также
сами значения площади пола и стен в доме пользователь будет вводить вручную.
Пример выполнения программы:
Введите цену за 1 кв.м паркета:
490
Введите цену за 1 кв.м обоев:
199
Какова площадь поверхности пола в доме?
50
Какова площадь поверхности стен в доме?
95
Стоимость паркета для ремонта: 24500
Стоимость обоев для ремонта: 18905
Общая стоимость покупки составит 43405 рублей

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Grayr2005
28.06.2020 09:43

#include <iostream>

#include <cmath>

using namespace std;

#define ld long double

struct triangle{

   ld a;

   ld b;

   ld c;

};

ld square(triangle t){

   ld p = (t.a + t.b + t.c)/2;

   return sqrt(p * (p - t.a) * (p - t.b) * (p - t.c));

}

triangle t1,t2;

void solve(){

   if(square(t1) == square(t2))

       cout << "ИСТИНА";

   else

       cout << "ЛОЖЬ";

}

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   cin >> t1.a >> t1.b >> t1.c >> t2.a >> t2.b >> t2.c;

   solve();

}

0,0(0 оценок)
Ответ:
danila110420051
28.06.2020 09:43

using System;

namespace ConsoleApp5

{

   class Program

   {

       static void Main(string[] args)

       {

           bool f;

           double a,b,c, s, s1;

           a = double.Parse(Console.ReadLine());

           b = double.Parse(Console.ReadLine());

           c = double.Parse(Console.ReadLine());

           s = Math.Sqrt(((a + b + c) / 2) * (((a + b + c) / 2) - a) * (((a + b + c) / 2) - b) * (((a + b + c) / 2) - c));

           a = double.Parse(Console.ReadLine());

           b = double.Parse(Console.ReadLine());

           c = double.Parse(Console.ReadLine());

           s1= Math.Sqrt(((a + b + c) / 2) * (((a + b + c) / 2) - a) * (((a + b + c) / 2) - b) * (((a + b + c) / 2) - c));

           if (s == s1)

               f = true;

           else

               f = false;

           Console.WriteLine(f);

           Console.ReadKey();

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота