calusiker
08.06.2023 16:33

Program n_2;
const pi=3.14;
var r,c,s: real;
begin
writeln('Вычисление длины окружности и площиди круга');
write('Введите r>>);
readln(r);
c:=2p*pi*r;
s:=pi*r*r;
writeln ('c=', c:6:4);
writeln ('s=', s:6:4)
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastyanas4
21.04.2023 17:11
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
0,0(0 оценок)
Ответ:
karinakatushkiowsqqh
03.02.2022 19:37
Как мы видим и различаем цвета?
Как мы видим и различаем цвета. Цветное зрение нам запомнить объекты и активизирует наши эмоции. Но знаете ли Вы, что объекты не имеют цвета? То, что мы видим на самом деле — это отражения световых волн и наш мозг интерпретирует их как цвет.

Видимый спектр для людей включает все цвета от фиолетового до красного. Подсчитано, что люди могут различать до 10 миллионов оттенков.

Когда свет попадет на объект, он поглощает часть этого света и отражает остальное, что проходит в наш глаз через роговицу, то есть внешнюю часть глаза. Роговица преломляет этот свет для его прохождения через зрачок, который регулирует количество света, попадающего на хрусталик. Он, в свою очередь, фокусирует свет на сетчатке, на слое нервных клеток, расположенных в глазном дне.
Как палочки и колбочки влияют на восприятие цвета?
В сетчатке имеются два типа клеток, которые реагируют на свет и поглащают его. Это палочки и колбочки, светочувствительные клетки, известные как фоторецепторы. Колбочки активируются в условиях низкой освещенности. Тем временем как палочки, стимулируются при большей освещённости. У большинства людей есть около 6 миллионов колбочек и 110 миллионов палочек.

Колбочки содержат пигменты или молекулы, которые определяют цвет. У людей, как правило, имеются три типа пигментов: красный, зеленый и синий. По чувствительности к свету с различными длинами волн различают три вида колбочек .

Наглядный пример того, как мы видим и различаем цвета: при дневном свете отраженный от лимона свет активирует два типа колбочек — красные и зелёные. Колбочки посылают это сигнал через зрительный нерв в зрительную зону коры головного мозга, который обрабатывает количество активированных колбочек и силу посылаемого сигнала. После обработки нервных импульсов клетками головного мозга мы видим цвет, который в данном случае является жёлтым.

В темноте, отражённый от лимона свет стимулирует только палочки, поэтому мы не видим цвета, а только оттенки серого.

Тем не менее, наш предыдущий визуальный опыт с объектами также влияет на восприятие цвета, известного как постоянство воспринимаемого цвета. Это постоянство гарантируют нам, что восприятие цвета объекта остается неизменным в различных условиях освещения. Даже если мы поместили лимон под красным светом, мы продолжаем воспринимать его как жёлтый.
Аномалии цветового зрения
Аномалии цветового зрения могут произойти, если один или несколько типов колбочек не воспринимают свет так, как должны. Может быть, что колбочки отсутствуют, не функционируют или не правильно различают цвет. Дальтонизм (не различать красный и зеленый цвета) является наиболее распространенной аномалией.

Исследователи подсчитали, что почти 12% женщин имеют 4 типа колбочек, вместо 3, что позволяет им различать количество цветов в 100 раз выше, чем те, у кого их только 3.

В животном мире, некоторые птицы, насекомые и рыбы также имеют 4 типа колбочек, позволяющие им видеть ультрафиолетовое излучение, не поспринимаемое человеческим глазом. Другие животные, как собаки, имеют меньше типов колбочек, что делает их цветовое зрение ниже, чем у людей.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота